color_rgb_a 0.0.1+1

color_rgb_a #

Represents a color in the red-green-blue scheme with an optional alpha component. Designed for use with both Flutter and CSS.

Deprecated #

This class has been incorporated into the shared_theme package. Specifically, here.

[0.0.1+1] - October 1, 2018

[0.0.1] - August 25, 2018

  • First release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  color_rgb_a: ^0.0.1+1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:color_rgb_a/color_rgb_a.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
46
Learn more about scoring.

We analyzed this package on Aug 22, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:color_rgb_a/color_rgb_a.dart.

Health suggestions

Fix lib/color_rgb_a.dart. (-1.49 points)

Analysis of lib/color_rgb_a.dart reported 3 hints:

line 11 col 28: Use = to separate a named parameter from its default value.

line 11 col 42: Use = to separate a named parameter from its default value.

line 11 col 55: Use = to separate a named parameter from its default value.

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and color_rgb_a.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0 <3.0.0
Dev dependencies
test ^1.3.0