cognitive_services 0.0.2

cognitive-dart #

An unofficial DART wrapper for Microsoft Azure Cognitive Services.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  cognitive_services: ^0.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:cognitive_services/cognitive_services.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
11
Health:
Code health derived from static analysis. [more]
91
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
49
Overall:
Weighted score of the above. [more]
43
Learn more about scoring.

We analyzed this package on Jan 17, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4

Health issues and suggestions

Document public APIs. (-0.30 points)

82 out of 84 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/language/bing_spell_check/bing_spell_check_response.dart. (-3.45 points)

Analysis of lib/language/bing_spell_check/bing_spell_check_response.dart reported 7 hints, including:

line 12 col 23: Unnecessary new keyword.

line 14 col 27: Unnecessary new keyword.

line 20 col 39: Unnecessary new keyword.

line 43 col 21: Unnecessary new keyword.

line 45 col 25: Unnecessary new keyword.

Fix lib/language/translate_text/translate_text_response.dart. (-2.96 points)

Analysis of lib/language/translate_text/translate_text_response.dart reported 6 hints, including:

line 11 col 11: Unnecessary new keyword.

line 14 col 22: Unnecessary new keyword.

line 16 col 26: Unnecessary new keyword.

line 22 col 39: Unnecessary new keyword.

line 45 col 39: Unnecessary new keyword.

Fix lib/language/translate_text/translate_text_service.dart. (-1.49 points)

Analysis of lib/language/translate_text/translate_text_service.dart reported 3 hints:

line 14 col 3: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 34 col 3: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 36 col 29: Unnecessary new keyword.

Fix lib/language/bing_spell_check/bing_spell_check.dart. (-1 points)

Analysis of lib/language/bing_spell_check/bing_spell_check.dart reported 2 hints:

line 14 col 3: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 24 col 3: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

Maintenance issues and suggestions

Provide a file named CHANGELOG.md. (-20 points)

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Package is getting outdated. (-10.68 points)

The package was last published 57 weeks ago.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and cognitive_services.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <3.0.0
convert >=1.0.0 <3.0.0 2.1.1
Transitive dependencies
charcode 1.1.2
typed_data 1.1.6
Dev dependencies
test any