code_confirmation 1.0.3
code_confirmation: ^1.0.3

Flutter Android iOS web

A widget with numerical keyboard and 4 inputs, usefull for hight secured confirmation with 2 step

0
likes
90 / 110
pub points
0 %
popularity

We analyzed this package on Nov 22, 2020, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 5 out of 37 API elements (13.5 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: This class (or a class that this class inherits from) is marked as '@immutable', but one or more of its instance fields aren't final: Keyboard.codeOutput

lib/code_confirmation/keyboard.dart:5:7

  ╷
5 │ class Keyboard extends StatelessWidget {
  │       ^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/code_confirmation/keyboard.dart

lib/code_confirmation/index.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

No dependencies.

Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
90
pub points
0%
popularity

A widget with numerical keyboard and 4 inputs, usefull for hight secured confirmation with 2 step

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

geremy.eaton@gmail.com

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on code_confirmation