large Flutter Favorite logosmall Flutter Favorite logo

cloud_functions 1.0.0-1.0.nullsafety.0 icon indicating copy to clipboard operation
cloud_functions: ^1.0.0-1.0.nullsafety.0 copied to clipboard

A Flutter plugin allowing you to use Firebase Cloud Functions.

255
likes
70/ 130
pub points
98%
popularity

We analyzed this package 28 days ago, and awarded it 70 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: Failed to run dartdoc

  • Failed to resolve dependencies.
stdout: [  +97 ms] executing: uname -m
[  +57 ms] Exit code 0 from: uname -m
[        ] x86_64
[  +10 ms] executing: [/tool/stable/flutter/] git -c log.showSignature=false log -n 1 --pretty=format:%H
[  +11 ms] Exit code 0 from: git -c log.showSignature=false log -n 1 --pretty=format:%H
[        ] cf4400006550b70f28e4b4af815151d1e74846c6
[   +1 ms] executing: [/tool/stable/flutter/] git tag --points-at cf4400006550b70f28e4b4af815151d1e74846c6
[  +18 ms] Exit code 0 from: git tag --points-at cf4400006550b70f28e4b4af815151d1e74846c6
[        ] 2.8.0
[  +11 ms] executing: [/tool/stable/flutter/] git rev-parse --abbrev-ref --symbolic @{u}
[   +7 ms] Exit code 128 from: git rev-parse --abbrev-ref --symbolic @{u}
[        ] fatal: HEAD does not point to a branch
[  +69 ms] Unable to locate an Android SDK.
[   +4 ms] executing: [/tool/stable/flutter/] git rev-parse --abbrev-ref HEAD
[   +7 ms] Exit code 0 from: git rev-parse --abbrev-ref HEAD
[        ] HEAD
[  +94 ms] Artifact Instance of 'AndroidGenSnapshotArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'AndroidInternalBuildArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'IOSEngineArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'FlutterWebSdk' is not required, skipping update.
[...]
[        ] Artifact Instance of 'MacOSEngineArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'LinuxEngineArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'LinuxFuchsiaSDKArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'MacOSFuchsiaSDKArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'FlutterRunnerSDKArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'FlutterRunnerDebugSymbols' is not required, skipping update.
[        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'FontSubsetArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'PubDependencies' is not required, skipping update.
[  +19 ms] executing: /tool/stable/flutter/bin/cache/dart-sdk/bin/dart __deprecated_pub upgrade --verbose
MSG : Resolving dependencies...
[+1751 ms] "flutter pub" took 1,871ms.
[   +4 ms] Running shutdown hooks
[        ] Shutdown hooks complete
[   +2 ms] exiting with code 1

stderr: FINE: Pub 2.15.0
SLVR: fact: cloud_functions is 1.0.0-1.0.nullsafety.0
SLVR: derived: cloud_functions
SLVR: fact: cloud_functions depends on cloud_functions_platform_interface >=4.0.2-1.0.nullsafety.2 <4.0.2-2.0.nullsafety.0
SLVR: fact: cloud_functions depends on cloud_functions_web >=3.1.4-1.0.nullsafety.2 <3.1.4-2.0.nullsafety.0
SLVR: fact: cloud_functions depends on firebase_core >=1.0.0-1.0.nullsafety.0 <1.0.0-2.0.nullsafety.0
SLVR: fact: cloud_functions depends on firebase_core_platform_interface >=4.0.0-1.0.nullsafety.1 <4.0.0-2.0.nullsafety.0
SLVR: fact: cloud_functions depends on flutter from sdk
SLVR:   selecting cloud_functions
SLVR:   derived: flutter from sdk
SLVR:   derived: firebase_core_platform_interface >=4.0.0-1.0.nullsafety.1 <4.0.0-2.0.nullsafety.0
SLVR:   derived: firebase_core >=1.0.0-1.0.nullsafety.0 <1.0.0-2.0.nullsafety.0
SLVR:   derived: cloud_functions_web >=3.1.4-1.0.nullsafety.2 <3.1.4-2.0.nullsafety.0
SLVR:   derived: cloud_functions_platform_interface >=4.0.2-1.0.nullsafety.2 <4.0.2-2.0.nullsafety.0
IO  : Get versions from https://pub.dartlang.org/api/packages/cloud_functions_platform_interface.
IO  : Get versions from https://pub.dartlang.org/api/packages/cloud_functions_web.
IO  : Get versions from https://pub.dartlang.org/api/packages/firebase_core.
IO  : Get versions from https://pub.dartlang.org/api/packages/firebase_core_platform_interface.
IO  : HTTP GET https://pub.dartlang.org/api/packages/cloud_functions_platform_interface
    | Accept: application/vnd.pub.v2+json
[...]
           <asynchronous suspension>
           #4      AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:150:19)
           <asynchronous suspension>
           #5      CommandRunner.runCommand (package:args/command_runner.dart:209:13)
           <asynchronous suspension>
           #6      FlutterCommandRunner.runCommand.<anonymous closure> (package:flutter_tools/src/runner/flutter_command_runner.dart:288:9)
           <asynchronous suspension>
           #7      AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:150:19)
           <asynchronous suspension>
           #8      FlutterCommandRunner.runCommand (package:flutter_tools/src/runner/flutter_command_runner.dart:236:5)
           <asynchronous suspension>
           #9      run.<anonymous closure>.<anonymous closure> (package:flutter_tools/runner.dart:62:9)
           <asynchronous suspension>
           #10     AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:150:19)
           <asynchronous suspension>
           #11     main (package:flutter_tools/executable.dart:94:3)
           <asynchronous suspension>



icon indicating section status
Support multiple platforms
0 / 20icon to trigger folding of the section

0/20 points: Supports 0 of 2 possible platforms (native, js)

Package resolution failed. Could not determine platforms.

Run dart pub get for more information.

icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run flutter pub outdated: dart pub get failed:
OUT:
Resolving dependencies...
ERR:
Because firebase_core >=1.0.0-1.0.nullsafety.0 <1.0.0 depends on firebase_core_web >=1.0.0-1.0.nullsafety.0 <1.0.0-2.0.nullsafety.0 and cloud_functions_web >=3.1.4-1.0.nullsafety.1 <3.1.4-nullsaf[...]
So, because cloud_functions depends on both cloud_functions_web >=3.1.4-1.0.nullsafety.2 <3.1.4-2.0.nullsafety.0 and firebase_core >=1.0.0-1.0.nullsafety.0 <1.0.0-2.0.nullsafety.0, version solvin[...]

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Unable to detect null safety

Package resolution failed. Could not determine null safety.

Run dart pub get for more information.

Analysed with Pana 0.21.4, Flutter 2.8.0, Dart 2.15.0.