clabe_dart 1.0.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 70

Build Status Coverage Status

Requerimientos #

Dart 2.1.0 o superior.

Uso básico #

Obtener el dígito de control de un número CLABE

import 'package:clabe_dart/clabe_dart.dart';

main() {
  computeControlDigit('03218000011835971');
}

Para validar si un número CLABE es válido

import 'package:clabe_dart/clabe_dart.dart';

main() {
  validateClabe('03218000011835971');
}

Para obtener el banco a partir de 3 dígitos

import 'package:clabe_dart/clabe_dart.dart';

main() {
  getBankName('002');
}

1.0.0 #

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  clabe_dart: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:clabe_dart/clabe_dart.dart';
  
Version Uploaded Documentation Archive
1.1.2 Jan 23, 2019 Go to the documentation of clabe_dart 1.1.2 Download clabe_dart 1.1.2 archive
1.1.1 Jan 22, 2019 Go to the documentation of clabe_dart 1.1.1 Download clabe_dart 1.1.1 archive
1.1.0 Jan 22, 2019 Go to the documentation of clabe_dart 1.1.0 Download clabe_dart 1.1.0 archive
1.0.2 Jan 14, 2019 Go to the documentation of clabe_dart 1.0.2 Download clabe_dart 1.0.2 archive
1.0.1 Jan 14, 2019 Go to the documentation of clabe_dart 1.0.1 Download clabe_dart 1.0.1 archive
1.0.0 Jan 14, 2019 Go to the documentation of clabe_dart 1.0.0 Download clabe_dart 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
53
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
70
Learn more about scoring.

We analyzed this package on May 8, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.0
  • pana: 0.12.15

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:clabe_dart/clabe_dart.dart.

Health issues and suggestions

Document public APIs. (-1 points)

6 out of 6 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/src/banks.dart.

Run dartfmt to format lib/src/banks.dart.

Format lib/src/clabe_validation.dart.

Run dartfmt to format lib/src/clabe_validation.dart.

Format lib/src/validations.dart.

Run dartfmt to format lib/src/validations.dart.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and clabe_dart.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
dart_coveralls ^0.6.0 0.6.0+4
Transitive dependencies
args 1.5.1
async 2.2.0
charcode 1.1.2
collection 1.14.11
convert 2.1.1
coverage 0.12.4
crypto 2.0.6
file 5.0.7
http 0.11.3+17 0.12.0+2
http_parser 3.1.3
intl 0.15.8
json_rpc_2 2.1.0
logging 0.11.3+2
meta 1.1.7
package_config 1.0.5
path 1.6.2
pub_semver 1.4.2
source_span 1.5.5
stack_trace 1.9.3
stream_channel 2.0.0
string_scanner 1.0.4
term_glyph 1.1.0
typed_data 1.1.6
vm_service_client 0.2.6+2
web_socket_channel 1.0.12
yaml 2.1.15
Dev dependencies
test ^1.5.1+1