cielo_payment_link 1.1.1
cielo_payment_link: ^1.1.1 copied to clipboard

A Flutter package that helps the shopkeeper create payment links. Its main objective is to allow stores to create links, through their own application and share with their customers, without the need [...]

1
likes
80/ 130
pub points
0%
popularity

We analyzed this package on Oct 19, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too long.

Search engines display only the first part of the description. Try to keep the value of the description field in your package's pubspec.yaml file between 60 and 180 characters.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 4 out of 228 API elements (1.8 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run flutter pub outdated: dart pub get failed:
OUT:
Resolving dependencies...
ERR:
The current Dart SDK version is 2.14.3.

Because test >=1.16.0-nullsafety <1.16.0-nullsafety.8 requires SDK version >=2.10.0-0 <2.12.0 and test >=1.16.0-nullsafety.8 <1.16.0-nullsafety.18 depends on typed_data >=1.3.0-nullsafety <1.3.0,[...]
And because test >=1.16.0-nullsafety.18 <1.16.0-nullsafety.19 depends on test_api 0.2.19-nullsafety.7, test >=1.16.0-nullsafety <1.16.0-nullsafety.19 requires typed_data >=1.3.0-nullsafety <1.3.0[...]
And because test >=0.12.0-beta.3 <1.3.0 requires SDK version >=1.8.0 <2.0.0-∞ and test >=1.3.0 <1.12.0 depends on boolean_selector ^1.0.0, test >=0.12.0-beta.3 <1.12.0-∞ or >=1.16.0-nullsafety <1[...]
And because test >=1.12.0 <1.13.0 depends on test_api 0.2.14 and test >=1.13.0 <1.14.5 depends on test_api 0.2.15, test >=0.12.0-beta.3 <1.14.5-∞ or >=1.16.0-nullsafety <1.16.0-nullsafety.19 requ[...]
And because test >=1.14.5 <1.15.0 depends on test_api 0.2.16 and test >=1.15.0 <1.15.3 depends on test_api 0.2.17, test >=0.12.0-beta.3 <1.15.3-∞ or >=1.16.0-nullsafety <1.16.0-nullsafety.19 requ[...]
And because test >=1.15.3 <1.15.5 depends on test_api 0.2.18 and test >=1.15.5 <1.16.0-nullsafety depends on test_api 0.2.18+1, test >=0.12.0-beta.3 <1.16.0-nullsafety.19 requires typed_data >=1.[...]
And because test >=1.16.0-nullsafety.19 <1.16.6 depends on test_api 0.2.19 and every version of flutter_test from sdk depends on boolean_selector 2.1.0, if test >=0.12.0-beta.3 <1.16.6 and flutte[...]
And because every version of flutter_test from sdk depends on both typed_data 1.3.0 and test_api 0.4.2, flutter_test from sdk is incompatible with test >=0.12.0-beta.3 <1.16.6.
[3 more lines]

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.

1
likes
80
pub points
0%
popularity

A Flutter package that helps the shopkeeper create payment links. Its main objective is to allow stores to create links, through their own application and share with their customers, without the need to access the Backoffice.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

cielo_oauth, dio, flutter

More

Packages that depend on cielo_payment_link