chengguo_audio_recorder_v2 0.0.2

  • Readme
  • Changelog
  • Example
  • Installing
  • 57

flutter_audio_recorder_v2 #

pub package

I just updated the Kotlin version

A flutter plugin for audio record.

Note: This plugin is still under development, and some APIs might not be available yet. Feedback welcome and Pull Requests are most welcome!

Preview #

chengguo-audio-recorder

Support platform #

  • [x] Android
  • [x] iOS

Installation #

First, add chengguo_audio_recorder as a dependency in your pubspec.yaml file.

dependencies:
  chengguo_audio_recorder

On iOS you need to add a usage description to info.plist:

<key>NSMicrophoneUsageDescription</key>
<string>This sample uses the microphone to record your speech and convert it to text.</string>
<key>UIBackgroundModes</key>
<array>
	<string>audio</string>
</array>

Example #

  1. Start record
var path = await AudioRecorder.startRecord();
  1. Stop record
await AudioRecorder.stopRecord();
  1. Determine whether the recording
var isRecording = await AudioRecorder.isRecording();

Error code #

Error codeRemark
PERMISSION_DENIEDRequest permission is denied.
OPTIONS_ERROROptions error.

0.0.2 #

  • More recent Kotlin version

0.0.1+1 #

  • Optimize

0.0.1 #

  • Release v0.0.1

example/lib/main.dart

import 'dart:async';

import 'package:audio_recorder/audio_recorder.dart';
import 'package:flutter/material.dart';

void main() => runApp(MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  bool _isRecording = false;
  String _audioPath;
  Timer _timer;
  int _tick = 0;
  double _db = 0;

  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
        appBar: AppBar(title: const Text('Plugin example app')),
        body: Center(
          child: Column(
            crossAxisAlignment: CrossAxisAlignment.center,
            children: <Widget>[
              Padding(
                padding: EdgeInsets.only(top: 50),
                child: Text("${_tick}s  ${_db}db",
                    style: TextStyle(fontSize: 40, color: Colors.blue)),
              ),
              MaterialButton(
                onPressed: _isRecording ? null : () => _startRecord(),
                child: Text("Start"),
                color: Colors.green,
              ),
              MaterialButton(
                onPressed: _isRecording ? () => _stopRecord() : null,
                child: Text("Stop"),
                color: Colors.red,
              ),
              Column(
                crossAxisAlignment: CrossAxisAlignment.start,
                mainAxisSize: MainAxisSize.min,
                children: <Widget>[
                  Text("    Output audio path:"),
                  Container(
                    margin: EdgeInsets.symmetric(horizontal: 10, vertical: 10),
                    padding: EdgeInsets.symmetric(horizontal: 5, vertical: 3),
                    decoration: BoxDecoration(
                        color: Colors.grey,
                        borderRadius: BorderRadius.all(Radius.circular(4))),
                    child: Text(
                      "${_audioPath ?? "Empty"}",
                      style: TextStyle(color: Colors.white),
                    ),
                  ),
                ],
              ),
            ],
          ),
        ),
      ),
    );
  }

  _startRecord() async {
    try {
      var path = await AudioRecorder.startRecord();
      debugPrint("path: $path");
      var isRecording = await AudioRecorder.isRecording();
      setState(() {
        _audioPath = path;
        _isRecording = isRecording;
      });
      _timer = Timer.periodic(Duration(seconds: 1), (timer) async {
        double db = await AudioRecorder.db;
        setState(() {
          _tick = timer.tick;
          _db = db.floorToDouble();
        });
      });
    } catch (e) {
      debugPrint("$e");
    }
  }

  _stopRecord() async {
    try {
      await AudioRecorder.stopRecord();
    } catch (e) {
      debugPrint("$e");
    } finally {
      _timer?.cancel();
      var isRecording = await AudioRecorder.isRecording();
      setState(() {
        _audioPath = null;
        _tick = 0;
        _isRecording = isRecording;
      });
    }
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  chengguo_audio_recorder_v2: ^0.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:chengguo_audio_recorder_v2/audio_recorder.dart';
import 'package:chengguo_audio_recorder_v2/error_code.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
26
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
57
Learn more about scoring.

We analyzed this package on Jul 2, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform linux

Because of import path [package:chengguo_audio_recorder_v2/audio_recorder.dart] that declares support for platforms: android, ios

Package does not support Flutter platform macos

Because of import path [package:chengguo_audio_recorder_v2/audio_recorder.dart] that declares support for platforms: android, ios

Package does not support Flutter platform web

Because of import path [package:chengguo_audio_recorder_v2/audio_recorder.dart] that declares support for platforms: android, ios

Package does not support Flutter platform windows

Because of import path [package:chengguo_audio_recorder_v2/audio_recorder.dart] that declares support for platforms: android, ios

Package not compatible with SDK dart

because of import path [chengguo_audio_recorder_v2] that is in a package requiring null.

Health issues and suggestions

Document public APIs. (-1 points)

10 out of 10 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8
Dev dependencies
flutter_test