cgi_versoes_helper 1.0.6

  • Readme
  • Changelog
  • Installing
  • 54

cgi_versoes_helper #

Pacote para controle de Versão dos Aplicativos da CGI Software.

Instalação. #

Adicione o cgi_versoes_helper: 1.0.6 no pubspec.yaml do seu aplicativo.

Utilização. #

Para acessar a tela de Sobre : CGISobrePage() Para acessar a tela de Notas de Versão : CGINotasVersaoPage()

Funcionalidades. #

  • Tela de Sobre mostrando a versão atual do app, e se existe alguma nova versão cadastrada no repositório do projeto na Firebase.
  • Tela de Sobre mensagem informativa em apps com versões desatualizadas com link para atualizar o app na Google Play Store.
  • Tela de Notas de Versão que recupera as informações disponíveis para cada versão no repositório do projeto na Firebase.

Dependências. #

O Pacote faz utilização dos seguintes pacotes: cloud_firestore, url_launcher, package_info, intl

[1.0.6] - 22/05/2020. #

  • Adicionada validação do modo do build (debug/release) para verificar versão mais recente do app.
  • Ajustada ordenação das notas de versão para visualização de modo decrescente.

[1.0.5] - 22/05/2020. #

  • Adicionada dependencia do cloud_firestore.

[1.0.4] - 22/05/2020. #

  • Removida dependencia fixa do cloud_firestore.

[1.0.3] - 22/05/2020. #

  • Criada documentação.

[1.0.2] - 22/05/2020. #

  • Padronização do Pacote.

[1.0.1] - 20/05/2020. #

  • Corrigido label do botão de notas de versão.

[1.0.0] - 20/05/2020. #

  • Integração com Firebase.

[0.0.1] - 19/05/2020. #

  • Criação do Pacote.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  cgi_versoes_helper: ^1.0.6

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:cgi_versoes_helper/cgi_notas_versao.page.dart';
import 'package:cgi_versoes_helper/cgi_sobre.page.dart';
import 'package:cgi_versoes_helper/models/versao.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
22
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
65
Overall:
Weighted score of the above. [more]
54
Learn more about scoring.

We analyzed this package on Jul 9, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform linux

Because:

  • package:cgi_versoes_helper/cgi_notas_versao.page.dart that imports:
  • package:cgi_versoes_helper/models/versao.dart that imports:
  • package:cloud_firestore/cloud_firestore.dart that declares support for platforms: android, ios

Package does not support Flutter platform macos

Because:

  • package:cgi_versoes_helper/cgi_notas_versao.page.dart that imports:
  • package:cgi_versoes_helper/models/versao.dart that imports:
  • package:cloud_firestore/cloud_firestore.dart that declares support for platforms: android, ios

Package does not support Flutter platform web

Because:

  • package:cgi_versoes_helper/cgi_notas_versao.page.dart that imports:
  • package:cgi_versoes_helper/models/versao.dart that imports:
  • package:cloud_firestore/cloud_firestore.dart that declares support for platforms: android, ios

Package does not support Flutter platform windows

Because:

  • package:cgi_versoes_helper/cgi_notas_versao.page.dart that imports:
  • package:cgi_versoes_helper/models/versao.dart that imports:
  • package:cloud_firestore/cloud_firestore.dart that declares support for platforms: android, ios

Package not compatible with SDK dart

Because:

  • cgi_versoes_helper that is a package requiring null.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

exitCode: 255 stdout: Documenting cgi_versoes_helper... Initialized dartdoc with 609 libraries in 118.2 seconds Generating docs for library cgi_versoes_helper from package:cgi_versoes_helper/cgi_notas_versao.page.dart... Generating docs for library cgi_versoes_helper from package:cgi_versoes_helper/cgi_sobre.page.dart... Generating docs for library versao from package:cgi_versoes_helper/models/versao.dart... Validating docs... Documented 3 public libraries in 15.1 seconds stderr: warning: cgi_versoes_helper has no library level documentation comments, from cgi_versoes_helper: (file:///tmp/pub-dartlang-dartdocBDANRL/pkg/lib/cgi_notas_versao.page.dart:1:9) warning: cgi_versoes_helper has no library level documentation comments, from cgi_versoes_helper: (file:///tmp/pub-dartlang-dartdocBDANRL/pkg/lib/cgi_sobre.page.dart:1:9) error: failed to write file at: cgi_versoes_helper/cgi_versoes_helper-library.html for symbol cgi_versoes_helper: (file:///tmp/pub-dartlang-dartdocBDANRL/pkg/lib/cgi_sobre.page.dart:1:9) conflicting with file already generated by cgi_versoes_helper: (file:///tmp/pub-dartlang-dartdocBDANRL/pkg/lib/cgi_notas_versao.page.dart:1:9) Dartdoc generates a path and filename to write to for each symbol. cgi_versoes_helper conflicts with another symbol in the generated path, and therefore can not be written out. Changing the name, library name, or class name (if appropriate) of one of the conflicting items can resolve the conflict. Alternatively, use the @nodoc tag in one symbol's documentation comments to hide it. warning: dartdoc generated a broken link to: cgi_versoes_helper/CGINotasVersaoPage-class.html (from index.json) warning: dartdoc generated a broken link to: cgi_versoes_helper/CGINotasVersaoPage/CGINotasVersaoPage.html (from index.json) warning: dartdoc generated a broken link to: cgi_versoes_helper/CGINotasVersaoPage/createState.html (from index.json) found 5 warnings and 1 error Unhandled exception: dartdoc encountered 1 errors while processing. #0 Dartdoc.generateDocs (package:dartdoc/dartdoc.dart:225:9)

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (cloud_firestore).

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and cgi_versoes_helper.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Homepage URL is insecure. (-5 points)

Update the homepage field and use a secure (https) URL.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
cloud_firestore ^0.12.11 0.12.11 0.13.7
flutter 0.0.0
intl ^0.16.1 0.16.1
package_info ^0.4.0+18 0.4.1
url_launcher ^5.4.7 5.5.0
Transitive dependencies
charcode 1.1.3
collection 1.14.12 1.14.13
firebase 7.3.0
firebase_core 0.4.5
firebase_core_platform_interface 1.0.4
firebase_core_web 0.1.1+2
flutter_web_plugins 0.0.0
http 0.12.1
http_parser 3.1.4
js 0.6.2
matcher 0.12.8
meta 1.1.8 1.2.1
path 1.7.0
pedantic 1.9.0 1.9.1
platform_detect 1.4.0
plugin_platform_interface 1.0.2
pub_semver 1.4.4
quiver 2.1.3
sky_engine 0.0.99
source_span 1.7.0
stack_trace 1.9.5
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6 1.2.0
url_launcher_linux 0.0.1+1
url_launcher_macos 0.0.1+7
url_launcher_platform_interface 1.0.7
url_launcher_web 0.1.2
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test