cerebral 0.0.2

  • Installing
  • Versions
  • 45

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  cerebral: ^0.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:cerebral/cerebral.dart';
  
Version Uploaded Documentation Archive
0.0.5 Jan 17, 2019 Go to the documentation of cerebral 0.0.5 Download cerebral 0.0.5 archive
0.0.4 Jan 17, 2019 Go to the documentation of cerebral 0.0.4 Download cerebral 0.0.4 archive
0.0.3 Jan 17, 2019 Go to the documentation of cerebral 0.0.3 Download cerebral 0.0.3 archive
0.0.2 Jan 17, 2019 Go to the documentation of cerebral 0.0.2 Download cerebral 0.0.2 archive
0.0.1 Dec 20, 2018 Go to the documentation of cerebral 0.0.1 Download cerebral 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
32
Health:
Code health derived from static analysis. [more]
92
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
10
Overall:
Weighted score of the above. [more]
45
Learn more about scoring.

We analyzed this package on May 8, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.0
  • pana: 0.12.15
  • Flutter: 1.5.8

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-1 points)

48 out of 48 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/src/persistor.dart. (-3.45 points)

Analysis of lib/src/persistor.dart reported 7 hints, including:

line 14 col 10: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 26 col 3: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 28 col 3: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 30 col 3: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 32 col 3: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

Fix lib/src/generators/helper.dart. (-2.48 points)

Analysis of lib/src/generators/helper.dart reported 5 hints:

line 3 col 1: The class 'Stream' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 5 col 12: The class 'Stream' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 6 col 23: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 13 col 13: The class 'Stream' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 16 col 16: The class 'Stream' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

Fix lib/src/generators/store.dart. (-1 points)

Analysis of lib/src/generators/store.dart reported 2 hints:

line 21 col 38: 'classElements' is deprecated and shouldn't be used.

line 36 col 29: 'classElements' is deprecated and shouldn't be used.

Fix additional 3 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/cerebral.dart (Run flutter format to format lib/cerebral.dart.)
  • lib/src/state.dart (Run flutter format to format lib/src/state.dart.)
  • lib/src/store.dart (Run flutter format to format lib/src/store.dart.)

Maintenance issues and suggestions

Provide a file named README.md. (-30 points)

The README.md file should inform others about your project, what it does, and how they can use it. See the example generated by stagehand.

Provide a file named CHANGELOG.md. (-20 points)

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and cerebral.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
shared_preferences ^0.4.3 0.4.3 0.5.2
source_gen ^0.9.1+3 0.9.4+2
Transitive dependencies
analyzer 0.36.3
args 1.5.1
async 2.2.0
build 1.1.4
charcode 1.1.2
collection 1.14.11
convert 2.1.1
crypto 2.0.6
csslib 0.16.0
dart_style 1.2.7
front_end 0.1.18
glob 1.1.7
html 0.14.0+2
kernel 0.3.18
logging 0.11.3+2
meta 1.1.6 1.1.7
package_config 1.0.5
path 1.6.2
pedantic 1.6.0
pub_semver 1.4.2
sky_engine 0.0.99
source_span 1.5.5
string_scanner 1.0.4
term_glyph 1.1.0
typed_data 1.1.6
vector_math 2.0.8
watcher 0.9.7+10
yaml 2.1.15