carp_context_package 0.9.1
carp_context_package: ^0.9.1 copied to clipboard

CARP context sampling package. Samples location, mobility, activity, weather, air-quality, and geofence.

6
likes
80/ 130
pub points
66%
popularity

We analyzed this package on Oct 3, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/cph-cachet/carp.sensing-flutter/tree/master/carp_context_package was unreachable.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 151 out of 309 API elements (48.9 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:carp_context_package/context.dart that imports:
  • package:mobility_features/mobility_features.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS.
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run flutter pub outdated: dart pub get failed:
OUT:
Resolving dependencies...
ERR:
The current Dart SDK version is 2.14.2.

    Because test >=1.16.0 depends on typed_data ^1.3.0 and test >=1.16.0-nullsafety.8 <1.16.0-nullsafety.18 depends on boolean_selector >=2.1.0-nullsafety <2.1.0, test >=1.16.0-nullsafety.8 <1.16[...]
(1) So, because test >=1.3.0 <1.12.0 depends on boolean_selector ^1.0.0, test >=1.3.0 <1.12.0-∞ or >=1.16.0-nullsafety.8 <1.16.0-nullsafety.18 or >=1.16.0 requires typed_data ^1.3.0 or boolean_se[...]

    Because test >=1.12.0 <1.13.0 depends on test_api 0.2.14 and test >=1.13.0 <1.14.5 depends on test_api 0.2.15, test >=1.12.0 <1.14.5 requires test_api 0.2.14 or 0.2.15.
    And because test >=1.14.5 <1.15.0 depends on test_api 0.2.16 and test >=1.15.0 <1.15.3 depends on test_api 0.2.17, test >=1.12.0 <1.15.3 requires test_api 0.2.14 or 0.2.15 or 0.2.16 or 0.2.17.
    And because test >=1.3.0 <1.12.0 depends on boolean_selector ^1.0.0 and test >=1.15.3 <1.15.5 depends on test_api 0.2.18, test >=1.3.0 <1.15.5 requires test_api 0.2.14 or 0.2.15 or 0.2.16 or [...]
    And because test >=1.16.0-nullsafety.19 <1.16.6 depends on test_api 0.2.19 and test >=1.15.5 <1.16.0-nullsafety depends on test_api 0.2.18+1, test >=1.3.0 <1.16.0-nullsafety or >=1.16.0-nulls[...]
    And because test >=1.16.0-nullsafety.18 <1.16.0-nullsafety.19 depends on test_api 0.2.19-nullsafety.7 and test >=1.16.0-nullsafety.8 <1.16.0-nullsafety.18 depends on typed_data >=1.3.0-nullsa[...]
[23 more lines]

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.3.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.2, Flutter 2.5.1, Dart 2.14.2.