A Flutter simple Carousel Widget.
As simple as using any flutter Widget. The Carousel package hides all the complexity (almost none, it's Flutter!) of implementing a carousel.
First things first, add the module to your project
... dependencies: ... carousel: ^0.0.1 ...
And install it using
flutter packages get on your project folder. After that, just import the module and use it:
import 'package:carousel/carousel.dart'; //... new SizedBox( height: 240.0, child: new Carousel( children: [ new NetworkImage('https://pbs.twimg.com/profile_images/760249570085314560/yCrkrbl3_400x400.jpg'), new NetworkImage('https://webinerds.com/app/uploads/2017/11/d49396_d9c5d967608d4bc1bcf09c9574eb67c9-mv2.png') ].map((netImage) => new Image(image: netImage)).toList(), ), )
This code snippet creates an Carousel with an height of 240.0 that contains both the logos of Flutter and React native, as an example. Simples as that! 😄
Developed by Gabriel Valério firstname.lastname@example.org
Feel free to help!
Add this to your package's pubspec.yaml file:
dependencies: carousel: ^0.1.0
You can install packages from the command line:
$ pub get
$ flutter pub get
Alternatively, your editor might support
pub get or
flutter pub get.
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.1.0||Jan 21, 2018|
|0.0.1||Jan 21, 2018|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.
dartdoc successfully runs on your package's source files. (-10 points)
Dependencies were not resolved.