camsnap_plugin 0.0.2

  • Readme
  • Changelog
  • Example
  • Installing
  • 31

Camsnap plugin #

  • [x] android native camera preview
  • [x] tap focus
  • [x] camera image capture
  • [ ] ios native camera preview
  • [ ] error handling
  • [ ] extended camera control

Getting Started #

  • import package:camsnap_plugin/camera_view.dart

Available methods:

  • in dev

0.0.1 #

  • TODO: Describe initial release.

example/lib/main.dart

import 'package:flutter/material.dart';
import 'package:camsnap_plugin/camera_view.dart';
import 'package:path_provider/path_provider.dart';
import 'dart:io';

void main() => runApp(MaterialApp(home: CameraViewExample()));

class CameraViewExample extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    double screenHeight = MediaQuery.of(context).size.height;
    double screenWidth = MediaQuery.of(context).size.width;

    return Scaffold(
        //appBar: AppBar(title: const Text('Flutter CameraView example')),
        body: Column(children: [
          Center(
              child: Container(
                  width: screenWidth,
                  height: screenHeight,
                  child: CameraView(
                    onCameraViewCreated: _onCameraViewCreated,
                  ))),
        ]));
  }

  void _onCameraViewCreated(CameraViewController controller) async {
    Directory appDocDir = await getExternalStorageDirectory();
    appDocDir.exists().then((isExists) async {
      if (!isExists) {
        appDocDir = await getApplicationDocumentsDirectory();
      }
    });
    String dir = appDocDir.path + '/Nailsnap/images';
    new Directory(dir).exists().then((isExists) {
      if (!isExists) {
        new Directory(dir).create(recursive: true);
      }
    });
    print(await controller.captureImage(dir, 'IMG_' + new DateTime.now().millisecondsSinceEpoch.toString() + '.jpg'));
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  camsnap_plugin: ^0.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:camsnap_plugin/camsnap_plugin.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
7
Overall:
Weighted score of the above. [more]
31
Learn more about scoring.

We analyzed this package on Jul 7, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform linux

Because of import path [package:camsnap_plugin/camsnap_plugin.dart] that declares support for platforms: android, ios

Package does not support Flutter platform macos

Because of import path [package:camsnap_plugin/camsnap_plugin.dart] that declares support for platforms: android, ios

Package does not support Flutter platform web

Because of import path [package:camsnap_plugin/camsnap_plugin.dart] that declares support for platforms: android, ios

Package does not support Flutter platform windows

Because of import path [package:camsnap_plugin/camsnap_plugin.dart] that declares support for platforms: android, ios

Package not compatible with SDK dart

because of import path [camsnap_plugin] that is in a package requiring null.

Health suggestions

Format lib/camera_view.dart.

Run flutter format to format lib/camera_view.dart.

Format lib/camsnap_plugin.dart.

Run flutter format to format lib/camsnap_plugin.dart.

Maintenance issues and suggestions

Homepage URL isn't helpful. (-10 points)

Update the homepage field from pubspec.yaml: link to a website about the package or use the source repository URL.

Package is getting outdated. (-53.42 points)

The package was last published 80 weeks ago.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.1
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8