c8y_client 0.0.4
c8y_client: ^0.0.4 copied to clipboard

Dart client for Cumulocity IoT Platfom. Based on http://resources.cumulocity.com/documentation/javasdk/current/ and http://resources.cumulocity.com/documentation/websdk/client/

3
likes
70 / 130
pub points
40 %
popularity

We analyzed this package on Jun 11, 2021, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL is insecure.

Update the homepage field and use a secure (https) URL.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/c8y_client_example.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 125 API elements (1.6 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 34 issues. Showing the first 2:

lib/c8y_client.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/src/alarms/implementations/alarm.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
http^0.12.0+40.12.20.13.3
http_parser^3.1.43.1.44.0.0
json_annotation^3.0.13.1.14.0.1
logger^0.9.10.9.41.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.3.11.3.1
collection-1.15.01.15.0
path-1.8.01.8.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^0.12.0+4` on http does not support the stable version `0.13.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

The constraint `^3.1.4` on http_parser does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions http_parser to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.17.1, Dart 2.13.1.

3
likes
70
pub points
40%
popularity

Publisher

Unknown

Dart client for Cumulocity IoT Platfom. Based on http://resources.cumulocity.com/documentation/javasdk/current/ and http://resources.cumulocity.com/documentation/websdk/client/

Homepage

Documentation

API reference

License

Apache 2.0 (LICENSE.txt)

Dependencies

http, http_parser, json_annotation, logger

More

Packages that depend on c8y_client