Add Sass and Builder runner to the project pubspec.yaml:
dev_dependencies: build_runner: ^0.7.10+1 sass_builder: ^1.1.2
Create a SCSS file and import bulma and edit any variable you need:
// 1. Import the initial variables @import "packages/bulma_sass/scss/utilities/initial-variables"; @import "packages/bulma_sass/scss/utilities/functions"; // 2. Set your own initial variables // Update blue $blue: #72d0eb; // Add pink and its invert $pink: #ffb3b3; $pink-invert: #fff; // Add a serif family $family-serif: "Merriweather", "Georgia", serif; // 3. Set the derived variables // Use the new pink as the primary color $primary: $pink; $primary-invert: $pink-invert; // Use the existing orange as the danger color $danger: $orange; // Use the new serif family $family-primary: $family-serif; // 4. Setup your Custom Colors $linkedin: #0077b5; $linkedin-invert: findColorInvert($linkedin); $twitter: #55acee; $twitter-invert: findColorInvert($twitter); $github: #333; $github-invert: findColorInvert($github); // 5. Add new color variables to the color map. @import "packages/bulma_sass/scss/utilities/derived-variables"; $addColors: ( "twitter":($twitter, $twitter-invert), "linkedin": ($linkedin, $linkedin-invert), "github": ($github, $github-invert) ); $colors: map-merge($colors, $addColors); // 6. Import the rest of Bulma @import "packages/bulma_sass/scss/bulma";
Documentation for the Bulma framework can be found here Bulma Documentation
Report problems with this package to https://github.com/indiealexh/dart_bulma_sass
Report problems with the core framework to https://github.com/jgthms/bulma
Dart package is released under MIT license.
Original Code copyright 2017 Jeremy Thomas and released under the MIT license.
Add this to your package's pubspec.yaml file:
dependencies: bulma_sass: ^0.6.2
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
|0.7.1+1||Aug 7, 2018|
|0.7.1||May 11, 2018|
|0.7.0||Apr 17, 2018|
|0.6.2+3||Mar 30, 2018|
|0.6.2+2||Feb 14, 2018|
|0.6.2+1||Feb 12, 2018|
|0.6.2||Feb 12, 2018|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.
dartdoc successfully runs on your package's source files. (-10 points)
Dependencies were not resolved.
|Dart SDK||>=2.0.0-dev.3.0 <2.0.0|