bottom_navigation_dot 0.0.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 64

bottom_navigation_dot #

A new Flutter package which helps developers in creating bottom navigation dot

Screenshots #

  • [x] Set Background Color
  • [x] Time Animation
  • [x] Active Color
  • [x] Color
  • [x] Dot Padding

Usage #

Example

Let's get started #

1 - Depend on it #

Add this to your package's pubspec.yaml file: #

  dependencies:
    flutter:
      sdk: flutter
    bottom_navigation_dot:

2 - Install it #

install packages from the command line: #

flutter packages get

3 - Import it #

Now in your Dart code, you can use: #

import 'package:bottom_navigation_dot/bottom_navigation_dot.dart';

5 - Use it Bottom Navigation Dot #

      bottomNavigationBar: new BottomNavigationDot(
        paddingBottomCircle: 21,
        color: Colors.grey,
        backgroundColor: Colors.white,
        activeColor: Colors.amber,
        items: [
          new BottomNavigationDotItem(icon: Icons.edit,onTap: (){changePage("green");}),
          new BottomNavigationDotItem(icon: Icons.cached,onTap: (){changePage("red");}),
          new BottomNavigationDotItem(icon: Icons.cake,onTap: (){changePage("orange");}),
        ],
         milliseconds: 400,
      ),

Good luck ❤️

bottom-navigation-dot #

bottom-navigation-dot #

[0.0.1] - Release

  • A customizable bottom-navigation-bar

example/main.dart

import 'package:flutter/material.dart';
import 'package:bottom_navigation_dot/bottom_navigation_dot.dart';

import 'pages/green.dart';
import 'pages/orange.dart';
import 'pages/red.dart';

void main() => runApp(MyApp());


class MyApp extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      title: "demo",
      theme: new ThemeData(
        primaryColor: Colors.black
      ),
      home: HomePage(),
    );
  }
}

class HomePage extends StatefulWidget {
  @override
  State<StatefulWidget> createState() => HomeState();
}

class HomeState extends State<HomePage> {
  String currentPage;
  final Map<String , Widget> pageView =<String,Widget> {
    "green":GreenPage(),
    "red":RedPage(),
    "orange":OrangePage(),

  };
  changePage(String pagename){
     setState(() {
       currentPage = pagename;
       
     });
  }

  @override
  Widget build(BuildContext context) {
    return Scaffold(
      body: this.pageView[currentPage],
      bottomNavigationBar: new BottomNavigationDot(
        paddingBottomCircle: 21,
        color: Colors.grey,
        backgroundColor: Colors.white,
        activeColor: Colors.amber,
        items: [
          new BottomNavigationDotItem(icon: Icons.edit,onTap: (){changePage("green");}),
          new BottomNavigationDotItem(icon: Icons.cached,onTap: (){changePage("red");}),
          new BottomNavigationDotItem(icon: Icons.cake,onTap: (){changePage("orange");}),
        ],
         milliseconds: 400,
      ),


      
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  bottom_navigation_dot: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:bottom_navigation_dot/bottom_navigation_dot.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
32
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
64
Learn more about scoring.

We analyzed this package on Oct 22, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/bottom_navigation_dot.dart.

Run flutter format to format lib/bottom_navigation_dot.dart.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.28.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test