blw 1.0.0
blw: ^1.0.0 copied to clipboard

墨墨发布测试

0
likes
90 / 130
pub points
0 %
popularity

We analyzed this package on May 11, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
0 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

The package description contains too many non-ASCII characters.

The site uses English as its primary language. The content of the description field in your package's pubspec.yaml should primarily contain characters used in English.

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:13:49

   ╷
13 │ <p>Please file feature requests and bugs at the <a href="http://example.com/issues/replaceme">issue tracker</a>.</p>
   │                                                 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

0/5 points: Provide a valid CHANGELOG.md

`CHANGELOG.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of CHANGELOG.md in your package should primarily contain characters used in English.

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/blw_example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 4 API elements (50.0 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

No dependencies.

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.10.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Dart 2.12.4.

0
likes
90
pub points
0%
popularity

墨墨发布测试

Homepage

Documentation

API reference

Uploader

baoleiwei@gmail.com

License

BSD (LICENSE)

More

Packages that depend on blw