BlocX for Flutter.
For help getting started with Flutter, view our online documentation.
For help on editing package code, view the documentation.
Add this to your package's pubspec.yaml file:
dependencies: blocx_flutter: ^0.1.0
You can install packages from the command line:
$ flutter packages get
Alternatively, your editor might support
flutter packages get.
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.1.0||Dec 28, 2018|
|0.0.1||Dec 13, 2018|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on May 17, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
Detected platforms: Flutter
References Flutter, and has no conflicting libraries.
lib/src/bloc_widget.dart. (-0.50 points)
lib/src/bloc_widget.dart reported 1 hint:
line 26 col 18: The class 'Stream' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.
flutter format to format
The package description is too short. (-20 points)
Add more detail to the
description field of
pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.
Maintain an example. (-10 points)
Create a short demo in the
example/ directory to show how to use this package.
Common filename patterns include
blocx_flutter.dart. Packages with multiple examples should provide
For more information see the pub package layout conventions.