bloc_built 0.0.1
bloc_built: ^0.0.1 copied to clipboard

A new Flutter project.

0
likes
45 / 130
pub points
0 %
popularity

We analyzed this package on May 13, 2021, and awarded it 45 pub points (of a possible 130):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

No `CHANGELOG.md` found.

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 3 out of 19 API elements (15.8 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:bloc_built/bloc_build.dart that imports:
  • package:bloc_built/src/bloc_generator.dart that imports:
  • package:bloc_built/src/generators/bloc.dart that imports:
  • package:bloc_built/src/generators/stream.dart that imports:
  • package:bloc_built/src/helpers.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/utils.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:glob/src/io.dart that imports:
  • package:glob/src/io_export.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 24 issues. Showing the first 2:

INFO: Unused import: 'package:dart_style/dart_style.dart'.

lib/src/bloc_generator.dart:4:8

  ╷
4 │ import 'package:dart_style/dart_style.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/bloc_generator.dart

INFO: Unused import: 'dart:async'.

lib/src/generators/bloc_built_generator.dart:1:8

  ╷
1 │ import 'dart:async';
  │        ^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/generators/bloc_built_generator.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer>=0.32.2 <0.35.00.34.31.5.0
bloc_annotation^0.0.20.0.20.0.2
build>=0.12.6 <2.0.01.1.02.0.1
build_config>=0.2.6 <0.4.00.3.21.0.0
code_builder^3.1.33.7.04.0.0
dart_style^1.2.21.2.32.0.1
meta^1.1.61.3.01.3.0
path^1.3.21.8.01.8.0
rxdart^0.20.00.20.00.27.0
source_gen^0.9.00.9.4+11.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
args-1.6.02.1.0
async-2.6.12.6.1
built_collection-5.0.05.0.0
built_value-8.0.68.0.6
charcode-1.2.01.2.0
checked_yaml-1.0.42.0.1
clock-1.1.01.1.0
collection-1.15.01.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.1
csslib-0.17.00.17.0
file-5.2.16.1.0
fixnum-1.0.01.0.0
front_end-0.1.9+10.1.29
glob-1.2.02.0.1
html-0.15.00.15.0
intl-0.17.00.17.0
js-0.6.30.6.3
json_annotation-2.4.04.0.1
kernel-0.3.9+10.3.29
logging-0.11.41.0.1
matcher-0.12.100.12.10
node_interop-1.2.12.0.1
node_io-1.2.02.0.0
package_config-1.9.32.0.0
pedantic-1.11.01.11.0
plugin-0.2.0+30.2.0+3
pub_semver-1.4.42.0.0
pubspec_parse-0.1.81.0.0
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
watcher-0.9.7+151.0.0
yaml-2.2.13.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 7 issues. Showing the first 2:

The constraint `>=0.32.2 <0.35.0` on analyzer does not support the stable version `0.35.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

The constraint `>=0.12.6 <2.0.0` on build does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions build to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Dart 2.12.4.