bitsocket_connect 0.5.1

  • Readme
  • Changelog
  • Installing
  • 49

A plug and play Bitsocket for Flutter Web.

Usage #

Connect to Bitsocket:

import 'package:bitsocket_connect/bitsocket_connect.dart';
var query = {
    'v': 3,
    'q': {
      'find': {},
      'project': {"tx.h": 1}
    }
  };
  
  void process(tx){
   print(tx);
  }

var bitsocket=Bitsocket();
bitsocket.connect(query,process);

Close the connection: bitsocket.close()

0.5.0 #

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  bitsocket_connect: ^0.5.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:bitsocket_connect/bitsocket_connect.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
5
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
83
Overall:
Weighted score of the above. [more]
49
Learn more about scoring.

We analyzed this package on Jul 11, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.15

Analysis suggestions

Package not compatible with runtime flutter-native on Android

Because:

  • package:bitsocket_connect/bitsocket_connect.dart that imports:
  • package:bitsocket_connect/src/bitsocket_connect_base.dart that imports:
  • dart:html

Package not compatible with runtime flutter-native on Linux

Because:

  • package:bitsocket_connect/bitsocket_connect.dart that imports:
  • package:bitsocket_connect/src/bitsocket_connect_base.dart that imports:
  • dart:html

Package not compatible with runtime flutter-native on Windows

Because:

  • package:bitsocket_connect/bitsocket_connect.dart that imports:
  • package:bitsocket_connect/src/bitsocket_connect_base.dart that imports:
  • dart:html

Package not compatible with runtime flutter-native on iOS

Because:

  • package:bitsocket_connect/bitsocket_connect.dart that imports:
  • package:bitsocket_connect/src/bitsocket_connect_base.dart that imports:
  • dart:html

Package not compatible with runtime flutter-native on macOS

Because:

  • package:bitsocket_connect/bitsocket_connect.dart that imports:
  • package:bitsocket_connect/src/bitsocket_connect_base.dart that imports:
  • dart:html

Package not compatible with runtime native

Because:

  • package:bitsocket_connect/bitsocket_connect.dart that imports:
  • package:bitsocket_connect/src/bitsocket_connect_base.dart that imports:
  • dart:html

Package not compatible with runtime native-aot

Because:

  • package:bitsocket_connect/bitsocket_connect.dart that imports:
  • package:bitsocket_connect/src/bitsocket_connect_base.dart that imports:
  • dart:html

Health suggestions

Format lib/src/self_draining_queue.dart.

Run dartfmt to format lib/src/self_draining_queue.dart.

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and bitsocket_connect.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

The package description is too short. (-7 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
Dev dependencies
pedantic ^1.8.0
test ^1.6.0