bbloc_generator 0.1.2

  • Readme
  • Changelog
  • Installing
  • 40

bloc_generator #

A new Flutter package project.

Getting Started #

This project is a starting point for a Dart package, a library module containing code that can be shared easily across multiple Flutter or Dart projects.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

[0.1.0] - 2019/11/12 #

  • Add BlocStream annotation
  • Add Bind annotation
  • Add BlocSink annotation
  • Add SinkBind annotation
  • Add EventStream annotation

[0.1.1] - 2019/11/13 #

  • Update dependency's and fixed pubspec health suggestion

[0.1.2] - 2019/11/13 #

  • Update dependency's and fixed pubspec health suggestion

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  bbloc_generator: ^0.1.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:bbloc_generator/bbloc_generator.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
50
Overall:
Weighted score of the above. [more]
40
Learn more about scoring.

We analyzed this package on Apr 8, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6

Health issues and suggestions

Document public APIs. (-1 points)

2 out of 2 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Maintenance issues and suggestions

Support latest dependencies. (-40 points)

The version constraint in pubspec.yaml does not support the latest published versions for 4 dependencies (analyzer, build, dart_style, source_gen).

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and bbloc_generator.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
analyzer >=0.34.2 <=0.39.1 0.39.1 0.39.6
bbloc ^0.1.1 0.1.1
build >=1.0.0 <=1.2.1 1.2.1 1.2.2
code_builder ^3.2.0 3.2.1
dart_style >=1.0.0 <=1.3.3 1.3.3 1.3.4
meta ^1.1.7 1.1.8
source_gen >=0.9.0 <=0.9.4+6 0.9.4+6 0.9.5
Transitive dependencies
_fe_analyzer_shared 1.0.0 2.1.0
args 1.6.0
async 2.4.1
built_collection 4.3.2
built_value 7.0.9
charcode 1.1.3
collection 1.14.12
convert 2.1.1
crypto 2.1.4
csslib 0.16.1
fixnum 0.10.11
front_end 0.1.29
glob 1.2.0
html 0.14.0+3
js 0.6.1+1
kernel 0.3.29
logging 0.11.4
matcher 0.12.6
node_interop 1.0.3
node_io 1.0.1+2
package_config 1.9.3
path 1.6.4
pedantic 1.9.0
pub_semver 1.4.4
quiver 2.1.3
source_span 1.7.0
stack_trace 1.9.3
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
watcher 0.9.7+14
yaml 2.2.0
Dev dependencies
build_runner >=1.0.0 <=1.7.1
build_test ^0.10.0
test ^1.0.0