backdrop_flutter 0.0.1

  • Readme
  • Changelog
  • Installing
  • 57

Flutter BackDrop #

Google Material Design BackDrop widget for Android and IOS

Getting Started #

Add the backdrop dependency to your pubspec.yaml file.

backdrop: "^<version number>"

then run flutter packages get to install the dependency.

Images #

Example #

import 'package:flutter/material.dart';
 import 'package:backdrop/backdrop.dart';
 
 class MyHomePage extends StatefulWidget {
   @override
   _MyHomePageState createState() => _MyHomePageState();
 }
 
 class _MyHomePageState extends State<MyHomePage> {
   @override
   Widget build(BuildContext context) {
     return Backdrop(
       subHeader: "Items",
       appBarTitle: "BackDrop",
       backLayer: ListView(
         children: <Widget>[
           ListTile(
             leading: Icon(
               Icons.map,
               color: Colors.white,
             ),
             title: Text(
               "Map",
               style: TextStyle(color: Colors.white),
             ),
             selected: true,
           ),
           ListTile(
             enabled: false,
             leading: Icon(Icons.directions_car),
             title: Text(
               "Car",
             ),
           ),
           ListTile(
             enabled: true,
             leading: Icon(
               Icons.border_all,
               color: Colors.white,
             ),
             title: Text(
               "Borders",
               style: TextStyle(color: Colors.white),
             ),
           ),
           ListTile(
             enabled: false,
             leading: Icon(Icons.beach_access),
             title: Text(
               "Beaches",
             ),
           ),
           ListTile(
             enabled: true,
             leading: Icon(
               Icons.add_shopping_cart,
               color: Colors.white,
             ),
             title: Text(
               "SuperMarket",
               style: TextStyle(color: Colors.white),
             ),
           ),
         ],
       ),
       frontLayer: ListView.builder(
           itemCount: 30,
           itemBuilder: (context, index) {
             return ListTile(
               title: Text("name $index"),
             );
           }),
     );
   }
 }

[0.0.1] - TODO: Add release date. #

  • TODO: Describe initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  backdrop_flutter: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:backdrop_flutter/backdrop.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
25
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
73
Overall:
Weighted score of the above. [more]
57
Learn more about scoring.

We analyzed this package on Apr 4, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6
  • Flutter: 1.12.13+hotfix.8

Maintenance suggestions

The package description is too short. (-17 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Maintain an example.

None of the files in the package's example/ directory matches known example patterns.

Common filename patterns include main.dart, example.dart, and backdrop_flutter.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test