babylon_dart 0.8.0 icon indicating copy to clipboard operation
babylon_dart: ^0.8.0 copied to clipboard

Dart bindings for the BabylonJS 4.2 rendering engine for the web.

11
likes
80/ 130
pub points
40%
popularity

We analyzed this package 27 days ago, and awarded it 80 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

  • Found example at: example/README.md

0/10 points: 20% or more of the public API has dartdoc comments

  • 238 out of 7785 API elements (3.1 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Support multiple platforms
10 / 20icon to trigger folding of the section

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime native

Because:

  • package:babylon_dart/babylon_dart.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 132 issues. Showing the first 2:

lib/src/abstractactionmanager.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/src/abstractmesh.dart doesn't match the Dart formatter.

To format your files run: dart format .

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
js^0.6.20.6.30.6.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.10.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Dart 2.15.1.

11
likes
80
pub points
40%
popularity

Publisher

shield icon for verified publishersblimster.net

Dart bindings for the BabylonJS 4.2 rendering engine for the web.

Homepage

Documentation

API reference

License

MIT (LICENSE)

Dependencies

js

More

Packages that depend on babylon_dart