babylon_dart 0.1.0 icon indicating copy to clipboard operation
babylon_dart: ^0.1.0 copied to clipboard

Bindings for the BabylonJS 4.1 web rendering engine.

11
likes
70/ 130
pub points
43%
popularity

We analyzed this package 27 days ago, and awarded it 70 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
10 / 20icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

  • Found example at: example/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 2004 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Support multiple platforms
10 / 20icon to trigger folding of the section

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime native

Because:

  • package:babylon_dart/babylon_dart.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 50 issues. Showing the first 2:

lib/src/abstractscene.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/src/arcrotatecamera.dart doesn't match the Dart formatter.

To format your files run: dart format .

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
js^0.6.20.6.30.6.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.9.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Dart 2.15.1.

11
likes
70
pub points
43%
popularity

Publisher

shield icon for verified publishersblimster.net

Bindings for the BabylonJS 4.1 web rendering engine.

Homepage

Documentation

API reference

License

MIT (LICENSE)

Dependencies

js

More

Packages that depend on babylon_dart