b1serviceflayer 1.0.3

Dart native
Flutter Android iOS

A generic utility package for SAP Business One Service Layer client API programming

0
likes
70 / 110
pub points
24 %
popularity

We analyzed this package on Sep 22, 2020, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/b1serviceflayer_example.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 68 API elements (2.9 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:b1serviceflayer/b1serviceflayer.dart that imports:
  • package:b1serviceflayer/src/b1serviceflayer_base.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

lib/src/b1enumtypes.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/src/b1serviceflayer_base.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
http^0.12.0+20.12.20.12.2
intl^0.15.80.15.80.16.1
meta^1.1.61.2.31.2.3
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.1.31.1.3
collection-1.14.131.14.13
http_parser-3.1.43.1.4
path-1.7.01.7.0
source_span-1.7.01.7.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.15.8` on intl does not support the latest published version `0.16.1`

pubspec.yaml:12:9

   ╷
12 │   intl: ^0.15.8
   │         ^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
70
pub points
24%
popularity

A generic utility package for SAP Business One Service Layer client API programming

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

nemethmiklos1960@gmail.com

License

BSD (LICENSE.md)

Dependencies

http, intl, meta

More

Packages that depend on b1serviceflayer