aws_iam_api 0.0.2

  • Readme
  • Changelog
  • Example
  • Installing
  • 48

AWS API client for AWS Identity and Access Management #

Warning: This is a generated library, some operations may not work.

About the service: AWS Identity and Access Management (IAM) is a web service that you can use to manage users and user permissions under your AWS account. This guide provides descriptions of IAM actions that you can call programmatically. For general information about IAM, see AWS Identity and Access Management (IAM). For the user guide for IAM, see Using IAM. We recommend that you use the AWS SDKs to make programmatic API calls to IAM. However, you can also use the IAM Query API to make direct calls to the IAM web service. To learn more about the IAM Query API, see Making Query Requests in the Using IAM guide. IAM supports GET and POST requests for all actions. That is, the API does not require you to use GET for some actions and POST for others. However, GET requests are subject to the limitation size of a URL. Therefore, for operations that require larger sizes, use a POST request.

Contributors #

0.0.2 #

(git hash: c257fd15b32cd44c8bbff0a4381b708c02b4853a)

  • Updating generated RegExp pattern + latest API definitions. (#156)
  • Updating generated dev_dependencies blocks. (#155)

0.0.1 #

  • initial release

example/README.md

import 'package:aws_iam_api/iam-2010-05-08.dart';

void main() {
  final credentials = AwsClientCredentials(accessKey: '', secretKey: '');
  final service = IAM(region: 'eu-west-1', credentials: credentials);
  // See documentation on how to use IAM
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  aws_iam_api: ^0.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:aws_iam_api/iam-2010-05-08.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
48
Learn more about scoring.

We analyzed this package on Jun 11, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.9+1

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
shared_aws_api ^0.1.0 0.1.8
Transitive dependencies
charcode 1.1.3
collection 1.14.12
convert 2.1.1
crypto 2.1.5
http 0.12.1
http_parser 3.1.4
intl 0.16.1
json_annotation 3.0.1
meta 1.1.8
path 1.7.0
pedantic 1.9.0
petitparser 3.0.4
source_span 1.7.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
xml 4.2.0
Dev dependencies
build_runner ^1.8.1
build_verify ^1.1.1
json_serializable ^3.3.0
test ^1.14.2