auto_suggestion_text_field 0.1.1
auto_suggestion_text_field: ^0.1.1 copied to clipboard

Flutter Android iOS Linux macOS web Windows

Auto Suggestion TextField with support for customization. it can be use on iOS and android.

1
likes
80 / 110
pub points
29 %
popularity

We analyzed this package on Feb 27, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

0/10 points: Failed to run dartdoc

  • Running dartdoc failed with the following output:
  warning: unresolved doc reference [new DiagnosticsNode.message]
    from auto_suggestion_text_field.AutoSugesstionTextField.debugDescribeChildren: (file:///tool/stable/flutter/packages/flutter/lib/src/foundation/diagnostics.dart:3457:25)
    in documentation inherited from diagnostics.DiagnosticableTree.debugDescribeChildren: (file:///tool/stable/flutter/packages/flutter/lib/src/foundation/diagnostics.dart:3457:25)
  warning: unresolved doc reference [DiagnosticsProperty<Object>]
    from auto_suggestion_text_field.AutoSugesstionTextField.debugDescribeChildren: (file:///tool/stable/flutter/packages/flutter/lib/src/foundation/diagnostics.dart:3457:25)
    in documentation inherited from diagnostics.DiagnosticableTree.debugDescribeChildren: (file:///tool/stable/flutter/packages/flutter/lib/src/foundation/diagnostics.dart:3457:25)
  warning: unresolved doc reference [RenderTable.debugDescribeChildren]
    from auto_suggestion_text_field.AutoSugesstionTextField.debugDescribeChildren: (file:///tool/stable/flutter/packages/flutter/lib/src/foundation/diagnostics.dart:3457:25)
    in documentation inherited from diagnostics.DiagnosticableTree.debugDescribeChildren: (file:///tool/stable/flutter/packages/flutter/lib/src/foundation/diagnostics.dart:3457:25)
  warning: unresolved doc reference [int]
    from auto_suggestion_text_field.AutoSugesstionTextField.debugFillProperties: (file:///tool/stable/flutter/packages/flutter/lib/src/widgets/framework.dart:509:8)
    in documentation inherited from diagnostics.Diagnosticable.debugFillProperties: (file:///tool/stable/flutter/packages/flutter/lib/src/foundation/diagnostics.dart:3342:8)
  warning: unresolved doc reference [DiagnosticsTreeStyle]
    from auto_suggestion_text_field.AutoSugesstionTextField.debugFillProperties: (file:///tool/stable/flutter/packages/flutter/lib/src/widgets/framework.dart:509:8)
    in documentation inherited from diagnostics.Diagnosticable.debugFillProperties: (file:///tool/stable/flutter/packages/flutter/lib/src/foundation/diagnostics.dart:3342:8)
  warning: unresolved doc reference [ColorProperty]
    from auto_suggestion_text_field.AutoSugesstionTextField.debugFillProperties: (file:///tool/stable/flutter/packages/flutter/lib/src/widgets/framework.dart:509:8)
    in documentation inherited from diagnostics.Diagnosticable.debugFillProperties: (file:///tool/stable/flutter/packages/flutter/lib/src/foundation/diagnostics.dart:3342:8)
  warning: unresolved doc reference [Color]
    from auto_suggestion_text_field.AutoSugesstionTextField.debugFillProperties: (file:///tool/stable/flutter/packages/flutter/lib/src/widgets/framework.dart:509:8)
    in documentation inherited from diagnostics.Diagnosticable.debugFillProperties: (file:///tool/stable/flutter/packages/flutter/lib/src/foundation/diagnostics.dart:3342:8)
  warning: unresolved doc reference [IconDataProperty]
    from auto_suggestion_text_field.AutoSugesstionTextField.debugFillProperties: (file:///tool/stable/flutter/packages/flutter/lib/src/widgets/framework.dart:509:8)
    in documentation inherited from diagnostics.Diagnosticable.debugFillProperties: (file:///tool/stable/flutter/packages/flutter/lib/src/foundation/diagnostics.dart:3342:8)
  warning: unresolved doc reference [IconData]
    from auto_suggestion_text_field.AutoSugesstionTextField.debugFillProperties: (file:///tool/stable/flutter/packages/flutter/lib/src/widgets/framework.dart:509:8)
    in documentation inherited from diagnostics.Diagnosticable.debugFillProperties: (file:///tool/stable/flutter/packages/flutter/lib/src/foundation/diagnostics.dart:3342:8)
  warning: unresolved doc reference [TransformProperty]
    from auto_suggestion_text_field.AutoSugesstionTextField.debugFillProperties: (file:///tool/stable/flutter/packages/flutter/lib/src/widgets/framework.dart:509:8)
    in documentation inherited from diagnostics.Diagnosticable.debugFillProperties: (file:///tool/stable/flutter/packages/flutter/lib/src/foundation/diagnostics.dart:3342:8)
  warning: unresolved doc reference [Matrix4]
    from auto_suggestion_text_field.AutoSugesstionTextField.debugFillProperties: (file:///tool/stable/flutter/packages/flutter/lib/src/widgets/framework.dart:509:8)
    in documentation inherited from diagnostics.Diagnosticable.debugFillProperties: (file:///tool/stable/flutter/packages/flutter/lib/src/foundation/diagnostics.dart:3342:8)
  warning: auto_suggestion_text_field has no library level documentation comments, from auto_suggestion_text_field: (file:///tmp/pub-dartlang-dartdocGMVRLI/pkg/lib/suggestion_text_field.dart:1:9)
  error: failed to write file at: auto_suggestion_text_field/auto_suggestion_text_field-library.html
    for symbol auto_suggestion_text_field: (file:///tmp/pub-dartlang-dartdocGMVRLI/pkg/lib/suggestion_text_field.dart:1:9)
    conflicting with file already generated by auto_suggestion_text_field: (file:///tmp/pub-dartlang-dartdocGMVRLI/pkg/lib/auto_suggestion_text_field.dart:1:1)
            Dartdoc generates a path and filename to write to for each symbol.
            auto_suggestion_text_field conflicts with another symbol in the generated path, and
            therefore can not be written out.  Changing the name, library name, or
            class name (if appropriate) of one of the conflicting items can resolve
            the conflict.   Alternatively, use the @nodoc tag in one symbol's
            documentation comments to hide it.
found 12 warnings and 1 error
Unhandled exception:
dartdoc encountered 1 errors while processing.
#0      Dartdoc.generateDocs (package:dartdoc/dartdoc.dart:231:9)
<asynchronous suspension>
#1      main (file:///project/pkg/pub_dartdoc/bin/pub_dartdoc.dart:32:33)
<asynchronous suspension>
#2      _startIsolate.<anonymous closure> (dart:isolate-patch/isolate_patch.dart:299:32)
#3      _RawReceivePortImpl._handleMessage (dart:isolate-patch/isolate_patch.dart:168:12)
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: 'ancestorInheritedElementForWidgetOfExactType' is deprecated and shouldn't be used. Use getElementForInheritedWidgetOfExactType instead. This feature was deprecated after v1.12.1..

lib/blocs/bloc_provider.dart:25:17

   ╷
25 │         context.ancestorInheritedElementForWidgetOfExactType(type)?.widget;
   │                 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/blocs/bloc_provider.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
rxdart^0.22.00.22.60.25.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0
collection-1.15.0-nullsafety.31.15.0
meta-1.3.0-nullsafety.31.3.0
sky_engine-0.0.990.0.99
typed_data-1.3.0-nullsafety.31.3.0
vector_math-2.1.0-nullsafety.32.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.22.0` on rxdart does not support the latest published version `0.25.0`

pubspec.yaml:14:11

   ╷
14 │   rxdart: ^0.22.0
   │           ^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.14.10, Flutter 1.22.6, Dart 2.10.5.

1
likes
80
pub points
29%
popularity

Auto Suggestion TextField with support for customization. it can be use on iOS and android.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

stupidravi2009@gmail.com

License

MIT (LICENSE)

Dependencies

flutter, rxdart

More

Packages that depend on auto_suggestion_text_field