auto_api 0.0.1-alpha.3

  • Readme
  • Changelog
  • Installing
  • 0

AutoApi #

It automatically creates a client interface to call server's methods asynchronously

Initial state #

  • hubs_inspector can get a description of the methods in hubs.
  • added tests 89% coverage.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  auto_api: ^0.0.1-alpha.3

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:auto_api/exceptions/exceptions.dart';
import 'package:auto_api/hub.dart';
import 'package:auto_api/hubs_inspector.dart';
import 'package:auto_api/serializer.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.23.0 <2.0.0