audiofile_plugin 0.0.4
audiofile_plugin: ^0.0.4 copied to clipboard

Flutter Android iOS

Flutter plugin for reading local files.

0
likes
60 / 100
pub points
0 %
popularity

We analyzed this package on Mar 4, 2021, and awarded it 60 pub points (of a possible 100):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 10

10/10 points: Package has an example

  • Found example at: example/lib/main.dart
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:audiofile_plugin/audiofile_plugin.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 85 issues. Showing the first 2:

INFO: The value of the local variable 'duration' isn't used.

lib/album_music.dart:99:15

   ╷
99 │         final duration = new Duration(milliseconds: call.arguments);
   │               ^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/album_music.dart

INFO: Name non-constant identifiers using lowerCamelCase.

lib/album_music.dart:147:8

    ╷
147 │    int nbre_of_songs;
    │        ^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/album_music.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
shared_preferences^0.4.20.4.32.0.3
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
meta-1.3.01.3.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.4.2` on shared_preferences does not support the stable version `0.5.0`.

Try running dart pub upgrade --major-versions shared_preferences to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.2, Flutter 1.26.0-17.8.pre, Dart 2.12.0 (build 2.12.0-259.16.beta).