audiofile_plugin 0.0.4

audiofile_plugin #

A new Flutter plugin.

Getting Started #

For help getting started with Flutter, view our online documentation.

For help on editing plugin code, view the documentation.

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.

example/lib/main.dart

import 'package:flutter/material.dart';
import 'package:flutter/services.dart';
import 'package:audiofile_plugin/audiofile_plugin.dart';

void main() => runApp(new MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => new _MyAppState();
}

class _MyAppState extends State<MyApp> {
  String _platformVersion = 'Unknown';

  @override
  initState() {
    super.initState();
    initPlatformState();
  }

  // Platform messages are asynchronous, so we initialize in an async method.
  initPlatformState() async {
    String platformVersion;
    // Platform messages may fail, so we use a try/catch PlatformException.
    try {
      platformVersion = await AudiofilePlugin.platformVersion;
    } on PlatformException {
      platformVersion = 'Failed to get platform version.';
    }

    // If the widget was removed from the tree while the asynchronous platform
    // message was in flight, we want to discard the reply rather than calling
    // setState to update our non-existent appearance.
    if (!mounted)
      return;

    setState(() {
      _platformVersion = platformVersion;
    });
  }

  @override
  Widget build(BuildContext context) {
    return new MaterialApp(
      home: new Scaffold(
        appBar: new AppBar(
          title: new Text('Plugin example app'),
        ),
        body: new Center(
          child: new Text('Running on: $_platformVersion\n'),
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  audiofile_plugin: ^0.0.4

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:audiofile_plugin/audiofile_plugin.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
68
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
53
Overall:
Weighted score of the above. [more]
31
Learn more about scoring.

We analyzed this package on Sep 20, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.0
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.2

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-0.80 points)

296 out of 298 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/storemedia.dart. (-22.17 points)

Analysis of lib/storemedia.dart reported 50 hints, including:

line 2 col 8: Unused import: 'dart:math'.

line 15 col 16: 'commit' is deprecated and shouldn't be used.

line 21 col 7: Name non-constant identifiers using lowerCamelCase.

line 34 col 7: Name non-constant identifiers using lowerCamelCase.

line 46 col 7: Name non-constant identifiers using lowerCamelCase.

Fix lib/audiofile_plugin.dart. (-7.71 points)

Analysis of lib/audiofile_plugin.dart reported 16 hints, including:

line 35 col 3: Name non-constant identifiers using lowerCamelCase.

line 64 col 19: Name non-constant identifiers using lowerCamelCase.

line 68 col 40: Name non-constant identifiers using lowerCamelCase.

line 70 col 19: Name non-constant identifiers using lowerCamelCase.

line 72 col 9: The value of the local variable 'completer' isn't used.

Fix lib/equalizer.dart. (-1.99 points)

Analysis of lib/equalizer.dart reported 4 hints:

line 22 col 16: The value of the field '_tab' isn't used.

line 54 col 19: Avoid using braces in interpolation when not needed.

line 187 col 10: Name non-constant identifiers using lowerCamelCase.

line 229 col 10: Name non-constant identifiers using lowerCamelCase.

Fix additional 6 files with analysis or formatting issues. (-2.99 points)

Additional issues in the following files:

  • lib/audio_visualizer.dart (3 hints)
  • lib/album_music.dart (2 hints)
  • lib/artist_music.dart (1 hint)
  • lib/audio.dart (Run flutter format to format lib/audio.dart.)
  • lib/playlist_music.dart (Run flutter format to format lib/playlist_music.dart.)
  • lib/visualizer.dart (Run flutter format to format lib/visualizer.dart.)

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (shared_preferences).

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Package is getting outdated. (-7.12 points)

The package was last published 55 weeks ago.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.28.0 <3.0.0
flutter 0.0.0
shared_preferences ^0.4.2 0.4.3 0.5.3+4
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8