arch_foundations 0.2.0
arch_foundations: ^0.2.0 copied to clipboard

Flutter architecture foundations I use in my apps. Work in progress.

0
likes
80/ 130
pub points
0%
popularity

We analyzed this package on Nov 9, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/xiprox/arch_foundations was unreachable.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 12 out of 103 API elements (11.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run flutter pub outdated: dart pub get failed:
OUT:
Resolving dependencies...
ERR:
Because mockito >=4.0.0 <=4.1.1 depends on test_api ^0.2.1 and mockito >=4.1.1+1 <4.1.2 depends on test_api >=0.2.1 <0.4.0, mockito >=4.0.0 <4.1.2 requires test_api >=0.2.1 <0.4.0.
And because mockito >=4.1.2 <=5.0.0-nullsafety.7 depends on test_api ^0.2.19-nullsafety and every version of flutter_test from sdk depends on test_api 0.4.2, flutter_test from sdk is incompatible[...]
So, because arch_foundations depends on both flutter_test any from sdk and mockito ^4.1.0, version solving failed.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.

0
likes
80
pub points
0%
popularity

Flutter architecture foundations I use in my apps. Work in progress.

Repository (missing)
View/report issues

Documentation

API reference

License

unknown (LICENSE)

Dependencies

bloc_event_gen, flutter, http, rxdart

More

Packages that depend on arch_foundations