angular_compiler 0.1.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 29

angular_compiler #

Tooling for compiling AngularDart.

0.1.0 #

  • Initial commit of angular_compiler.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  angular_compiler: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:angular_compiler/angular_compiler.dart';
  
Version Uploaded Documentation Archive
0.4.4 May 7, 2019 Go to the documentation of angular_compiler 0.4.4 Download angular_compiler 0.4.4 archive
0.4.3 Apr 5, 2019 Go to the documentation of angular_compiler 0.4.3 Download angular_compiler 0.4.3 archive
0.4.2 Dec 10, 2018 Go to the documentation of angular_compiler 0.4.2 Download angular_compiler 0.4.2 archive
0.4.1 Oct 10, 2018 Go to the documentation of angular_compiler 0.4.1 Download angular_compiler 0.4.1 archive
0.4.0 Aug 7, 2018 Go to the documentation of angular_compiler 0.4.0 Download angular_compiler 0.4.0 archive
0.3.0+1 Jan 9, 2018 Go to the documentation of angular_compiler 0.3.0+1 Download angular_compiler 0.3.0+1 archive
0.3.0 Aug 24, 2017 Go to the documentation of angular_compiler 0.3.0 Download angular_compiler 0.3.0 archive
0.2.1 Aug 15, 2017 Go to the documentation of angular_compiler 0.2.1 Download angular_compiler 0.2.1 archive
0.2.0 Aug 7, 2017 Go to the documentation of angular_compiler 0.2.0 Download angular_compiler 0.2.0 archive
0.1.1 Jul 12, 2017 Go to the documentation of angular_compiler 0.1.1 Download angular_compiler 0.1.1 archive

All 31 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
58
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
29
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.22.0 <2.0.0