angel_validate 3.0.0-alpha

Dart native
Flutter Android iOS

Strongly-typed form handlers and validators for the Angel framework.

3.0.0-alpha #

  • Rewrite, based on Field and Form, rather than strings.

2.0.2 #

  • Deduplicate error messages.

2.0.1+1 #

  • Fix bug in the implementation of maxLength.

2.0.1 #

  • Patch for updated body parsing.

2.0.0 #

  • Finish update for Angel 2.

2.0.0-alpha.1 #

  • Update for Angel 2.

1.0.5-beta #

  • Use wrapMatcher on explicit values instead of throwing.
  • Add async matchers.
  • Add context-aware matchers.

1.0.4 #

  • isNonEmptyString trims strings.
  • ValidationException extends AngelHttpException.
  • Added requireField and requireFields.
2
likes
90
pub points
80%
popularity

Publisher

angel-dart.dev

Strongly-typed form handlers and validators for the Angel framework.

Repository (GitHub)
View/report issues

License

MIT (LICENSE)

Dependencies

angel_framework, duration, html_builder, http_parser, image, matcher

More

Packages that depend on angel_validate