angel_mustache 1.1.0

  • Installing
  • Versions
  • 11

mustache #

Gitter version build status

Mustache (Handlebars) view generator for the Angel web server framework.

Thanks so much @c4wrd for his help with bringing this project to life!

Installation #

In pubspec.yaml:

    angel_mustache: ^1.1.0

Usage #

const FileSystem fs = const LocalFileSystem();

configureServer(Angel app) async {
  // Run the plug-in
  await app.configure(mustache('views')));
  // Render `hello.mustache`
  await res.render('hello', {'name': 'world'});

Options #

  • partialsPath: A path within the viewsDirectory to search for partials in. Default is ./partials.
  • fileExtension: The file extension to search for. Default is .mustache.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  angel_mustache: ^1.1.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:angel_mustache/angel_mustache.dart';
Version Uploaded Documentation Archive
2.0.0 Nov 8, 2018 Go to the documentation of angel_mustache 2.0.0 Download angel_mustache 2.0.0 archive
1.1.0 Nov 18, 2017 Go to the documentation of angel_mustache 1.1.0 Download angel_mustache 1.1.0 archive
1.0.3 Apr 5, 2017 Go to the documentation of angel_mustache 1.0.3 Download angel_mustache 1.0.3 archive
1.0.2 Jun 21, 2016 Go to the documentation of angel_mustache 1.0.2 Download angel_mustache 1.0.2 archive
1.0.1 May 2, 2016 Go to the documentation of angel_mustache 1.0.1 Download angel_mustache 1.0.1 archive
1.0.0 May 2, 2016 Go to the documentation of angel_mustache 1.0.0 Download angel_mustache 1.0.0 archive
1.0.0-dev Apr 22, 2016 Go to the documentation of angel_mustache 1.0.0-dev Download angel_mustache 1.0.0-dev archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0