angel_jinja 1.0.0-rc.0

Angel support for the Jinja2 templating engine, ported from Python to Dart.

1
likes
60 / 110
pub points
4 %
popularity

We analyzed this package on Sep 26, 2020, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 2 API elements (50.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:angel_jinja/angel_jinja.dart that imports:
  • package:jinja/jinja.dart that imports:
  • package:jinja/src/loaders.dart that imports:
  • package:jinja/src/env.dart that imports:
  • package:jinja/src/parser.dart that imports:
  • package:jinja/src/utils.dart that imports:
  • dart:mirrors
Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

ERROR: The named parameter 'defaultValue' isn't defined.

lib/angel_jinja.dart:43:7

   ╷
43 │       defaultValue: defaultValue,
   │       ^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/angel_jinja.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
angel_framework^2.0.0-alpha2.1.12.1.1
jinja^0.0.40.0.8+10.2.4
Transitive dependencies
PackageConstraintCompatibleLatest
angel_container-1.1.01.1.0
angel_http_exception-1.1.01.1.0
angel_model-1.0.31.0.3
angel_route-3.1.0+13.1.0+1
charcode-1.1.31.1.3
code_buffer-1.0.11.0.1
collection-1.14.131.14.13
combinator-1.1.01.1.0
convert-2.1.12.1.1
crypto-2.1.52.1.5
dart2_constant-1.0.2+dart21.0.2+dart2
file-5.2.15.2.1
http2-1.0.11.0.1
http_parser-3.1.43.1.4
http_server-0.9.8+30.9.8+3
intl-0.16.10.16.1
logging-0.11.40.11.4
matcher-0.12.90.12.9
merge_map-1.0.21.0.2
meta-1.2.31.2.3
mime-0.9.70.9.7
mock_request-1.0.71.0.7
quiver-2.1.32.1.3
quiver_hashcode-2.0.02.0.0
recase-2.0.13.0.0
source_span-1.7.01.7.0
stack_trace-1.9.51.9.5
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
tuple-1.0.31.0.3
typed_data-1.2.01.2.0
uuid-2.2.22.2.2

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.0.4` on jinja does not support the latest published version `0.2.4`

pubspec.yaml:10:10

   ╷
10 │   jinja: ^0.0.4
   │          ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

1
likes
60
pub points
4%
popularity

Publisher

angel-dart.dev

Angel support for the Jinja2 templating engine, ported from Python to Dart.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

angel_framework, jinja

More

Packages that depend on angel_jinja