angel_hot 1.1.1

  • Installing
  • Versions
  • 34

hot #


Supports hot reloading of Angel servers on file changes. This is faster and more reliable than merely reactively restarting a Process.

This package only works with the Angel framework.

Installation #

In your pubspec.yaml:

  angel_hot: ^1.0.0

Usage #

This package is dependent on the Dart VM service, so you must run Dart with the --enable-vm-service argument!!!

Usage is fairly simple. Pass a function that creates an Angel server, along with a collection of paths to watch, to the HotReloader constructor. The rest is history!!!

The recommended pattern is to only use hot-reloading in your application entry point. Create your Angel instance within a separate function, conventionally named createServer. Using this in production mode is pointless.

You can watch:

  • Files
  • Directories
  • Globs
  • URI's
  • package: URI's
import 'dart:async';
import 'dart:convert';
import 'dart:io';
import 'package:angel_compress/angel_compress.dart';
import 'package:angel_diagnostics/angel_diagnostics.dart';
import 'package:angel_framework/angel_framework.dart';
import 'package:angel_hot/angel_hot.dart';
import 'src/foo.dart';

main() async {
  var hot = new HotReloader(createServer, [
    new Directory('config'),
    new Directory('lib'),
    new Directory('web'),
    new Directory('src'),
  var server = await hot.startServer(InternetAddress.LOOPBACK_IP_V4, 3000);
      'Hot server listening at http://${server.address.address}:${server.port}');

Future<Angel> createServer() async {
  var app = new Angel();

  app.lazyParseBodies = true;

  app.get('/', {'hello': 'hot world!'});'/foo/bar', (req, res) async {
    var result = await someLengthyOperation();
    return {'status': result};

  app.after.add(() => throw new AngelHttpException.notFound());

  await app.configure(logRequests());
  return app;

1.1.1 #

  • Disable the observatory from pausing the isolate on exceptions, because Angel already handles all exceptions by itself.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  angel_hot: ^1.1.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:angel_hot/angel_hot.dart';
Version Uploaded Documentation Archive
2.0.6 May 6, 2019 Go to the documentation of angel_hot 2.0.6 Download angel_hot 2.0.6 archive
2.0.5 May 1, 2019 Go to the documentation of angel_hot 2.0.5 Download angel_hot 2.0.5 archive
2.0.4 Feb 7, 2019 Go to the documentation of angel_hot 2.0.4 Download angel_hot 2.0.4 archive
2.0.3 Nov 9, 2018 Go to the documentation of angel_hot 2.0.3 Download angel_hot 2.0.3 archive
2.0.2 Nov 6, 2018 Go to the documentation of angel_hot 2.0.2 Download angel_hot 2.0.2 archive
2.0.1 Nov 2, 2018 Go to the documentation of angel_hot 2.0.1 Download angel_hot 2.0.1 archive
2.0.0 Oct 2, 2018 Go to the documentation of angel_hot 2.0.0 Download angel_hot 2.0.0 archive
1.1.1+1 Jun 8, 2018 Go to the documentation of angel_hot 1.1.1+1 Download angel_hot 1.1.1+1 archive
1.1.1 Jun 7, 2018 Go to the documentation of angel_hot 1.1.1 Download angel_hot 1.1.1 archive
1.1.0 Dec 7, 2017 Go to the documentation of angel_hot 1.1.0 Download angel_hot 1.1.0 archive

All 16 versions...

Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.3.1.
 Because angel_websocket >=1.0.0-dev+1 <1.1.2 requires SDK version <2.0.0 and angel_websocket >=1.1.2 <2.0.0-alpha depends on uuid ^0.5.3, angel_websocket >=1.0.0-dev+1 <2.0.0-alpha requires uuid ^0.5.3.
 So, because uuid >=0.0.7 <1.0.3 requires SDK version <2.0.0 and angel_hot depends on angel_websocket ^1.1.0-alpha, version solving failed.

Health suggestions

Format lib/angel_hot.dart.

Run dartfmt to format lib/angel_hot.dart.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

The package description is too short. (-4 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example.

None of the files in the package's example/ directory matches known example patterns.

Common filename patterns include main.dart, example.dart, and angel_hot.dart. Packages with multiple examples should provide example/

For more information see the pub package layout conventions.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0 <3.0.0