angel_graphql 2.0.0-beta

Dart native
Flutter Android iOS

The fastest + easiest way to get a GraphQL backend in Dart, using Angel.

7
likes
75 / 100
pub points
65 %
popularity

We analyzed this package on Sep 13, 2020, and awarded it 75 pub points (of a possible 100):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:15:1

   ╷
15 │ <a href="http://facebook.github.io/graphql/October2016/#sec-Language">GraphQL specification</a> - these
   │ ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 10

10/10 points: Package has an example

  • Found example at: example/main.dart
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:angel_graphql/angel_graphql.dart that imports:
  • package:angel_graphql/src/resolvers.dart that imports:
  • package:angel_framework/angel_framework.dart that imports:
  • package:angel_framework/src/core/core.dart that imports:
  • package:angel_framework/src/core/service.dart that imports:
  • package:angel_framework/src/core/server.dart that imports:
  • package:angel_framework/src/core/routable.dart that imports:
  • package:angel_framework/src/core/response_context.dart that imports:
  • package:angel_framework/src/core/request_context.dart that imports:
  • package:http_server/http_server.dart that imports:
  • package:http_server/src/http_multipart_form_data.dart that imports:
  • package:http_server/src/http_multipart_form_data_impl.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
angel_file_service^2.0.02.0.12.0.1
angel_framework^2.0.02.1.12.1.1
angel_validate^2.0.02.0.22.0.2
angel_websocket^2.0.02.0.32.0.3
graphql_schema^1.0.01.0.41.0.4
graphql_server^2.0.0-beta2.0.0-beta1.0.3
http_parser^3.0.03.1.43.1.4
web_socket_channel^1.0.01.1.01.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
angel_auth-2.1.5+12.1.5+1
angel_client-2.0.22.0.2
angel_container-1.1.01.1.0
angel_http_exception-1.1.01.1.0
angel_model-1.0.31.0.3
angel_route-3.1.0+13.1.0+1
async-2.4.22.4.2
charcode-1.1.31.1.3
code_buffer-1.0.11.0.1
collection-1.14.131.14.13
combinator-1.1.01.1.0
convert-2.1.12.1.1
crypto-2.1.52.1.5
dart2_constant-1.0.2+dart21.0.2+dart2
gql-0.12.30.12.3
http-0.12.20.12.2
http2-1.0.01.0.0
http_server-0.9.8+30.9.8+3
intl-0.16.10.16.1
json_god-2.0.0-beta+31.0.1
matcher-0.12.90.12.9
merge_map-1.0.21.0.2
meta-1.2.31.2.3
mime-0.9.70.9.7
mock_request-1.0.71.0.7
path-1.7.01.7.0
pool-1.4.01.4.0
quiver-2.1.32.1.3
quiver_hashcode-2.0.02.0.0
recase-2.0.13.0.0
source_span-1.7.01.7.0
stack_trace-1.9.51.9.5
stream_channel-2.0.02.0.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
tuple-1.0.31.0.3
typed_data-1.2.01.2.0
uuid-2.2.22.2.2

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.0.0-beta` on graphql_server does not support the latest published version `1.0.3`

pubspec.yaml:14:19

   ╷
14 │   graphql_server: ^2.0.0-beta
   │                   ^^^^^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs