amap_core_fluttify 0.11.0 icon indicating copy to clipboard operation
amap_core_fluttify: ^0.11.0 copied to clipboard

An `Amap` Core Component, Powered By `Fluttify` Engine, A Dart Bindings Generator For Native SDK.

0
likes
75/ 130
pub points
83%
popularity

We analyzed this package 15 days ago, and awarded it 75 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
15 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

`README.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of README.md in your package should primarily contain characters used in English.

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

0/10 points: 20% or more of the public API has dartdoc comments

  • 6 out of 182 API elements (3.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:amap_core_fluttify/amap_core_fluttify.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:amap_core_fluttify/amap_core_fluttify.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:amap_core_fluttify/amap_core_fluttify.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:amap_core_fluttify/amap_core_fluttify.dart that declares support for platforms: Android, iOS.
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 27 issues. Showing the first 2:

INFO: The diagnostic 'non_constant_identifier_names' doesn't need to be ignored here because it's already being ignored.

lib/src/android/type_op.g.dart:15:21

   ╷
15 │ // ignore_for_file: non_constant_identifier_names, camel_case_types, missing_return, unused_import
   │                     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/android/type_op.g.dart

INFO: The diagnostic 'camel_case_types' doesn't need to be ignored here because it's already being ignored.

lib/src/android/type_op.g.dart:15:52

   ╷
15 │ // ignore_for_file: non_constant_identifier_names, camel_case_types, missing_return, unused_import
   │                                                    ^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/android/type_op.g.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
core_location_fluttify^0.4.00.4.10.7.1
flutterflutter0.0.00.0.0
foundation_fluttify^0.9.00.9.10+10.13.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.01.2.1
collection-1.16.01.16.0
material_color_utilities-0.1.40.1.5
meta-1.7.01.8.0
sky_engine-0.0.990.0.99
vector_math-2.1.22.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.4.0` on core_location_fluttify does not support the stable version `0.5.0`.

Try running dart pub upgrade --major-versions core_location_fluttify to update the constraint.

The constraint `^0.9.0` on foundation_fluttify does not support the stable version `0.10.0`.

Try running dart pub upgrade --major-versions foundation_fluttify to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.6.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.12, Flutter 3.0.1, Dart 2.17.1.

0
likes
75
pub points
83%
popularity

Publisher

verified publisher iconfluttify.com

An `Amap` Core Component, Powered By `Fluttify` Engine, A Dart Bindings Generator For Native SDK.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Icon for licenses.unknown (LICENSE)

Dependencies

core_location_fluttify, flutter, foundation_fluttify

More

Packages that depend on amap_core_fluttify