A new flutter package project.
For help getting started with Flutter, view our online documentation.
For help on editing package code, view the documentation.
Add this to your package's pubspec.yaml file:
dependencies: aes_cbc: ^0.0.4
You can install packages from the command line:
$ pub get
$ flutter pub get
Alternatively, your editor might support
pub get or
flutter pub get.
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Fix dependencies in
flutter pub upgrade failed with the following output:
ERR: The current Dart SDK version is 2.4.0. Because aes_cbc depends on bignum >=0.0.3 which requires SDK version <2.0.0, version solving failed.
Fix platform conflicts. (-20 points)
Error(s) prevent platform classification:
Fix dependencies in
dartdoc successfully runs on your package's source files. (-10 points)
Dependencies were not resolved.
The package description is too short. (-20 points)
Add more detail to the
description field of
pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.
Maintain an example. (-10 points)
Create a short demo in the
example/ directory to show how to use this package.
Common filename patterns include
aes_cbc.dart. Packages with multiple examples should provide
For more information see the pub package layout conventions.
Package is pre-v0.1 release. (-10 points)
While nothing is inherently wrong with versions of
0.0.*, it might mean that the author is still experimenting with the general direction of the API.
|Dart SDK||>=2.0.0-dev.63.0.flutter-4c9689c1d2 <3.0.0|