widget_record

A widget that help you record animation

Warning: the api may change as this is a very very early version

Current known limitations:

  • output format is only apng
  • the size of the recorded widget must not change

todo list:

  • increase performances with isolates
  • improve documentations
  • improve example
  • add output format (mp4, gif, etc)

⚙️ Installation

https://pub.dev/packages/widget_record/versions/0.0.1

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  widget_record: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:widget_record/widget_record.dart';
  

Libraries

widget_record