version_check_plugin

A new flutter plugin project.

Getting Started

This plugin checks the native version of Flutter app.

import 'package:flutter/material.dart'; import 'dart:async'; import 'package:flutter/services.dart'; import 'package:version_check_plugin/version_check_plugin.dart';

void main() { runApp(const MyApp()); }

class MyApp extends StatefulWidget { const MyApp({Key? key}) : super(key: key);

@override State

class _MyAppState extends State

@override void initState() { super.initState(); initPlatformState(); }

// Platform messages are asynchronous, so we initialize in an async method. Future

// If the widget was removed from the tree while the asynchronous platform
// message was in flight, we want to discard the reply rather than calling
// setState to update our non-existent appearance.
if (!mounted) return;

setState(() {
  _platformVersion = platformVersion;
});

}

@override Widget build(BuildContext context) { return MaterialApp( home: Scaffold( appBar: AppBar( title: const Text('Plugin example app'), ), body: Center( child: Text('Running on: $_platformVersion\n'), ), ), ); } }

Libraries

version_check_plugin