Smart Dropdown

Smart Dropdown is a package which shows a dropdown in an elegant way.

Install

Add this line to your pubspec.yaml:

dependencies:
  smart_dropdown: ^0.0.1

Then run this command:

$ flutter packages get

Then add this import:

import 'package:smart_dropdown/smart_dropdown.dart';

Basic Example

Basic example demonstrates the use of smart dropdown. It also has an option to select any item by default.

SmartDropDown(
            items: items,
            hintText: "Smart Dropdown Demo",
            borderRadius: 5,
            borderColor: Theme.of(context).primaryColor,
            expandedColor: Theme.of(context).primaryColor,
          )

Sample Image

Sample Image

License

BSD

Libraries

smart_dropdown