simple_bar_graph

Minimal graph for faily large dataset.

To install, add this to your dependencies

simple_bar_graph: ^0.1.0

Please enable SSH credentials for gitlab for this to work.

Usage

import 'package:simple_bar_graph/simple_bar_graph.dart';

...

@override
Widget build(BuildContext context) {
    final graphController = GraphController();
    graphController.addListener(() {
        final _selected = graphController.selected;

        print(_selected);
    })

    return SimpleBarGraph(
        controller: graphController,
    );
}

Example here: https://gitlab.com/bascule-credit/simple_bar_graph/snippets/1936308

TODOs

Allow customization to bars width

Allow toggle of group label visibility

Free utitlity to group data by dates

Documentation and clean up

Libraries

graph_controller
models
simple_bar_graph