reorder_tree_list

A reorder tree list widget for flutter.

Using the library

The /example/ folder in the GitHub repo contains a full Flutter app with demo examples.

Use this package as a library on Dart dev

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
    reorder_tree_list: ^0.1.1

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:reorder_tree_list/extension_reorder_list.dart';
import 'package:reorder_tree_list/tree_list_item.dart';

Demo

Demo

Libraries

extension_reorder_list
tree_list_item