process_run.dartbin library Null safety

Prefer using shell.

Constants

dartChannelBeta → const String
Beta channel.
'beta'
dartChannelDev → const String
Dev channel.
'dev'
dartChannelMaster → const String
Master channel.
'master'
dartChannelStable → const String
Stable channel.
'stable'

Properties

dartChannel String
Current dart platform channel
read-only
dartExecutable String?
Get dart vm either from executable or using the which command
read-only
dartSdkBinDirPath String
read-only
dartSdkDirPath String
read-only
dartVersion Version
Current dart platform version
read-only
isFlutterSupported bool
read-only
isFlutterSupportedSync bool
true if flutter is supported
read-only

Functions

getFlutterBinChannel() Future<String?>
Get flutter channel. (dev, beta, master, stable) [...]
getFlutterBinVersion() Future<Version?>
Get flutter version. [...]