Pub Package Github Actions CI

Getting started

In pubspec.yaml:

dependencies:
  nodejs_io: ^0.1.0

In main.dart:

import 'package:nodejs_io/nodejs_io.dart';
import 'package:universal_io/io.dart';

void main() async {
  nodeIODriver.enable();

  // 'dart:io' works now!
  final socket = await Socket.connect("localhost", 8080);
}

Libraries

nodejs_io
Contains an implementation of IODriver for Node.JS.