music_volume

This package is a plugin to change the volume.

Only Support android.media.AudioManager.STREAM_MUSIC, so very simple package.

Using

var _currentVolume = await MusicVolume.currentVolume;
var _maxVolume = await MusicVolume.maxVolume;
var _isMute = await MusicVolume.isMute;
await  MusicVolume.changeVolume(_maxVolume, 0);

// ・・・ playing music logic

await  MusicVolume.changeVolume(_currentVolume, _isMute);

Libraries

i18n
music_volume

Dart

VM

dart:ffi
Foreign Function Interface for interoperability with the C programming language. [...]

Web

dart:html
HTML elements and other resources for web-based applications that need to interact with the browser and the DOM (Document Object Model). [...]
dart:js
Low-level support for interoperating with JavaScript. [...]
dart:js_util
Utility methods to efficiently manipulate typed JSInterop objects in cases where the name to call is not known at runtime. You should only use these methods when the same effect cannot be achieved with @JS annotations. These methods would be extension methods on JSObject if Dart supported extension methods.