libclang.dart

Pub Package

Dart FFI bindings to libclang.

The package is still under initial development. Issues and PRs are welcome.

Warning

  • The package currently trys to call dynamic library /usr/lib/llvm-{9,10}/lib/libclang.so directly. Look at here for detail.

  • According to #41062 and #36730 from dart SDK, functions related to CXCursor are supported by a wrapper of libclang until official support of pass/return by value.

Setup Wrapper

Make sure you have g++ installed.

make

Libraries

libclang