Flutter Package Manager

Flutter Package Manager, powerfull package management via CLI, add/search/top/favorite packages!

Install

> pub global activate fpm

Usage

Without verbose

$ fpm top
$ fpm favorites
$ fpm search html
$ fpm search html --verbose
# Install a specific version
$ fpm add http

# Install to dev_dependencies
$ fpm add --dev http
❯ fpm --help     
Flutter Version Management: A cli to manage Flutter packages.

Usage: fpm <command> [arguments]

Global options:
-h, --help       Print this usage information.
    --verbose    Print verbose output.

Available commands:
  add         Add package SDK Version
  favorites   List of the flutter favorite packages
  search      Search dart packages
  top         List the top used dart packages

Run "fpm help <command>" for more information about a command.

Libraries

add
favorites
package
parser
pretty.printer
runner
top