flutter_native_channel

A fast flutter message channel by using dart FFI and shared memory.

  • Concurrent Channel

Run tasks concurrently in different thread.

  • Synchronous Channel

Run task sync synchronously using FFI call.

Requirements

  • Flutter 1.20+ / Dart 2.9+
  • Android NDK 21.3.6528147

Usage

Check out example.

Libraries

flutter_native_channel