Eralp Software package for Flutter

A Flutter package for help Eralp Software developers.

Installation

First, add eralpsoftware as a dependency in your pubspec.yaml file.

Example

import 'package:eralpsoftware/eralpsoftware.dart';
import 'package:flutter/material.dart';

class MyExample extends StatefulWidget {
  const MyExample({Key key}) : super(key: key);

  @override
  _MyExampleState createState() => _MyExampleState();
}

class _MyExampleState extends State<MyExample> {
  final Calculator _calculator = Calculator();

  int _count = 0;

  @override
  Widget build(BuildContext context) {
    return Scaffold(
      appBar: AppBar(
        title: Text('Example'),
      ),
      body: Container(
        child: Center(
          child: Text("$_count"),
        ),
      ),
      floatingActionButton: FloatingActionButton(
        onPressed: onPressed,
        child: Icon(Icons.add),
      ),
    );
  }

  void onPressed() {
    setState(() {
      _count += _calculator.addOne(_count);
    });
  }
}

Feedback

Please feel free to give us any feedback helping support this package!

Libraries

eralp_notification
eralp_notification_widget
eralpsoftware
global_provider
number_helper
numeric_input_formatter
splash_page
stream_provider
validators